Imagination PowerVR SDK Blog

After update, failed to load driver swrast


#1

Hi
I did a ‘yum update’ today on our CentOS 7 machine.
I am quite sure NVIDIA-Linux-x86_64-352.79 was installed (before the update, it was NVIDIA-Linux-x86_64-352.63)

Everything seems to be working normally and most OpenGL program work. However one OpenGL application reports
```
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

during start and then the GL windows are not drawn - they just contain the background.
Before the update this application worked correctly, and did not display the message about swrast.

However, swrast seems to be present:
<code>$ ls -l /usr/lib64/dri/*swrast*
-rwxr-xr-x. 7 root root 8292104 Nov 20 18:42 /usr/lib64/dri/kms_swrast_dri.so
-rwxr-xr-x. 7 root root 8292104 Nov 20 18:42 /usr/lib64/dri/swrast_dri.so</code>
In my ' /var/log/Xorg.0.log' there was no mention of 'swrast'.

Is it perhaps necessary to reinstall swrast?
If yes, which package would i have to install?

Can anybody help me fix this problem?

Thank You

#2

Hi,

I think this issue has to do with nvidia drivers. Have you tried reaching out to nvidia on their forums?

bests,
Marton