Imagination PowerVR SDK Blog

PVRTexToolCLI (2018 Release 1) doesn't work on macOS (High Sierra)

So, this is the general syntax as used by my wrapper:

/path/to/PVRTexToolCLI -i "input_file.PVR" -o "output_file.PVR" -f PVRTC1_4,UBN,lRGB -potcanvas + -squarecanvas +

The output file is always empty (i.e., it contains only transparent pixels). Everything works fine on Windows.

Any help would be really appreciated.

Hi Luke,

Thanks for reporting this. We will have a look at reproducing it and, hopefully, fixing it. I will let you know as soon as I gather more info.

Regards.

Carlos.

Do you need anything else from me?

Hi Luke,

I gave it a go on macOS Sierra (10.12.6) but I could replicate this issue and your command-line worked fine as far as I could tell. I cannot update our testing system to High Sierra right now, but I will try shortly. I am wondering whether this problem has to do with your input texture. Does it work if you input a png file? Could you attach a file that shows this problem?

Thanks.

Carlos.

Try with the following .PVR file

Hi Luke,

The problem is that your input format is BC1 and we do not support DXTC on Mac or Linux. This is related to the S3TC patent. This patent has expired recently and we should be able to add support for these formats, but we haven’t got around to do it.

Regards.

Carlos.

I see, thanks for clarifying.

Do you know when you add support for these formats? Is this one of your top priorities?

Hey, Carlos.

Do you have some (good) news on that patent? I mean, it’s so annoying this tool is Windows-only…

Hi Luke,

I am sorry we haven’t looked into this yet. Sadly, other priorities have got in the way. As soon as we do this, I will let you know.

Regards.

Carlos.

Hi Carlos,

is there any good news about this issue?

@CarlosSarria
Forgot to mention…

Also for the record, I have the same issue with 2019 Release 1

Hi Luke,

It should be there now. I have checked it on Mac and the DirectX formats are showing up as expected. Bear in mind that we only support BC1, BC2 and BC3.

Regards.

Carlos.

@CarlosSarria

I see, but it’s not working for me (macOS High Sierra)
Could you try with the input format I linked above and tell me if it’s working for you? Thanks in advance!

Hmmm, I tested just the GUI. For some reason the fix did not make to the CL version. I have tested the file you supplied and yes, the problem is still there. I have file a bug with high priority to get this sorted out.

Thanks.

Carlos.

@CarlosSarria

That’s good news!
Are you able to provide an ETA for this fix?

Hi Luke,

We will release a fixed version as part of our 19.2 release due by September.
I should be able to send you a preview version sooner.

Best regards.

Carlos.

Hi @CarlosSarria ,

Do you have any good news about this issue? Guess you didn’t manage to release the new version by September, did you? Anyway, I just wanted to know if you managed to test the CLI on your testing system and if it is working as intended now…

Hi Luke,

We are still doing testing for our 19.2 release and it has been slightly delayed. The fix you required is in it. If you want to get a preview drop us a ticket in https://pvrsupport.imgtec.com/ and we will share it with you.

Best regards.

Carlos.

@CarlosSarria Sure, why not.
Does it involve signing an NDA or something like that?

© Imagination Technologies Limited. All rights reserved.
Privacy PolicyTerms & ConditionsTrademarksCookies