Imagination PowerVR SDK Blog

64bit gcc problems


#1

Hi,

as I moved from a 32bit machine to a Ubuntu 64bit one I encountered the following new errors when I tried to compile our GLES applications with the emulation SDKs with gcc 4.3.2-1ubuntu12. I hope somebody can help me to solve these:

For GLES 1.1:

/usr/bin/ld: skipping incompatible /home/dev/GLES/Builds/OGLES/LinuxPC/Lib/libGLES_CL.so when searching for -lGLES_CL
/usr/bin/ld: cannot find -lGLES_CL
collect2: ld returned 1 exit status

Are the libraries available for 64bit to, or Is there a way to link the libraries on 64bit?

For GLES 2.0:

in the function:
context->eglDisplay = eglGetDisplay((EGLNativeDisplayType)EGL_DEFAULT_DISPLAY);

error: cast from ‘void*’ to ‘EGLNativeDisplayType’ loses precision

I tried different castings but it simply did not work out. Any ideas?
Regards
Clemens







#2

Hi again,
I managed to get rid of both errors by compiling our entire software suite in 32-bit mode. However, is there a plan to support 64-bit systems in the future?
Regards
Clemens


#3


Hi Clemens,


Yes, we want to release 32bit and 64bit versions of all our utilities in our nex SDK 2.5 due by August 2009.

Regards.


Carlos.