Imagination PowerVR SDK Blog

Bad texture corruption?


#1

I’m a bit new to the PVRTC format (and iOS development as a whole), but I’ve noticed something odd happening in some of my textures after they’ve been compressed.


I’ve used the PVRTexLib to compress our image data into PVRTC and load them into iOS. This has worked well except for a couple of textures.

For example, look at the difference between “before” and “after” compression on this image.



The image rotates in the application, but you can see how different from the source image it looks. It appears that something with the background/alpha has gone wrong and looks like transparent white is being displayed as opaque white. At first we believed that like all texture compression formats, some images just don’t compress very well. I ran the texture through Xcode’s textool and recieved very different results. (The image looks fine after compression through the tool).

I was wondering if anyone any ideas what could cause this, or if there’s some setting in the Compression code that I’m missing out that would lead to behavior like this.

#2

Finally hunted down what was going wrong. Some bad Premultiplied alpha. Question answered : )