Imagination PowerVR SDK Blog

Depth texture attachment failure when using the PVRFrame binairies

pvrvframe

#1

Hi,



I’m wondering if someone else is having the same problem. When I try to attack a depth texture to a framebuffer on an apple device it works just fine but when I try to do the same with the PVRFrame binaries from the SDK 3.0 or 3.1 it fails. I’m using the 64bits libraries.



Anyone else having this bug ?


#2

Hi,



I’ve tested the 3.1 SDK version of PVRVFrame with our ShadowMapping Example (which uses the GL_OES_depth_texture extension), and it works correctly for me. I’ve also checked the source for PVRVFrame’s device profile list, and all of them seem to support the extension.


  1. What OS are you using on your development machine?

  2. What GPU do you have in your development machine?

  3. Which Profile do you currently have selected in the PVRVFrame GUI application (found in (SDK_DIR)/PVRVFrame/Tools/PVRVFrameGUI/)?

  4. Can you explain how the depth texture bind fails? Does glCheckFramebufferStatus return with GL_FRAMEBUFFER_COMPLETE after the binding? Does glGetError return any error codes?



Thanks,
Joe

#3

I check the example that you are talking about and I figured out that the problem is to attach a pack depth and stencil buffer (GL_UNSIGNED_INT_24_8_OES). Attaching a simple depth buffer work just fine. For the question you were asking:

  1. Windows 7
  2. AMD Radeon HD 6900 Series
  3. OpenGL
  4. It returns GL_FRAMEBUFFER_UNSUPPORTED



    I was not aware about the profile. I’m currently using the dll with my application. Does PVRVFrame is setting something in the registry to set the DLL profile !?

#4

Hi,



PVRVFrame does not support OES_packed_depth_stencil or EXT_packed_depth_stencil. This is why GL_FRAMEBUFFER_UNSUPPORTED has been returned for your configuration.



All of our utilities store application state information in .plist files rather than using the Windows registry.



Thanks,

Joe


#5

Thanks you very much for your help! :slight_smile:


#6

You’re welcome :slight_smile:



Joe