Imagination PowerVR SDK Blog

glGenerateMipmap working on emulation ...


#1

… and not on hardware.





I’m not getting any GL error … but I get no texture (everything is black).





Any hint ?


#2

How do you create the texture, what is the size, format, etc?


#3

glTexImage2D( GL_TEXTURE_2D, 0, InternalFormat, Image->getDimension().Width,


                             Image->getDimension().Height, 0, PixelFormat, PixelType, source );





With InternalFormat and PixelFormat as GL_RGBA and PixelType as GL_UNSIGNED_BYTE





It happens with various textures of various size. for instance a 1024x1024.


#4

Hm, this looks like it should work. glGenerateMipmap won’t work for non-power-of-two textures or compressed textures, though. Does the glGenerateMipmap call immediately follow glTexImage2D?





What is the hardware/driver you’re running this on?


#5

I tried with npot and pot textures, i have the same result :





I’m using 3.01.00.02 drivers (angstrom) on an omap3 board (igepv2) … Last time I tried to update my system, it broke 3D support.