Imagination PowerVR SDK Blog

How to disable anti aliasing on the PC emulator


#1

I’m not sure why, but later versions of the PC emulator anti alias full screen by default. I have tried setting egl SAMPLE_BUFFERS to zero etc (this should be the default anyway), but I still get anti aliasing on poly edges and line drawing. Earlier versions of the PC emulator such as the one that came with SDK 3.0r2 doesn’t anti alias.



Is there a way to turn this off on version 3.3 that I’m missing?


#2

Hello



did you try :to set the shell with prefAASamples settings?



regards

david


#3

I’m not using the PVR shell (as far as I know).

I’m compiling it against the libEGL.lib and libGLESv2.lib that come with the SDK.


#4

Hi Tobyc



A quirk of EGL is that you can only specify the minimum number of multisample buffers, so specifying zero for EGL_SAMPLE_BUFFERS means you may still get an antialiased framebuffer config.



If you really need AA to be disabled then you could iterate through the returned configs and use eglGetConfigAttrib to find one with no multisample buffer.