Imagination PowerVR SDK Blog

OGLES PC Emulation: no content in window

pvrvframe

#1

Windows 7 64-bit Ultimate; ThinkPad T60p Core 2 Duo T7600 2.33 GHz; ATI MOBILITY FireGL V5250 driver version 8.561.0.0

 

If I run any of the demos in C:Imagination TechnologiesPOWERVR SDKOGLES2_WINDOWS_PCEMULATION_2.07.27.0484BinariesDemos the emulator will start up, I'll get a small PVRVFRAME window that counts up frames elapsed and fps rate.  There's a second window adjacent to it, entitled whatever the demo .exe is.

 

But there's no content in that window; that window is totally blank, whitespace.  All the demos are like this.

 

#2

We do run the demos on Windows 64bit, but not with this precise configuration. I presume that driver version is the latest one?

One of our engineers is looking into this and will post when he has more information.


#3

Gordon, thank you very much for replying.  I'm using the driver reported by Device Manager as Display adapter "ATI MOBILITY FireGL V5250," but have also tried the driver "Standard VGA Graphics Adapter" that was originally there after CD installation.  "ATI MOBILITY FireGL V5250" is 8.561.0.0 and is dated 12/1/2008 (i.e., US date format:  Dec. 1).  It was provided automatically to me 3 days ago via Windows Update (Control PanelSystem and SecurityWindows UpdateSelect updates to install).


(The only platform that I personally know the emulator to work on is a new Gateway delivered within the past three months (with Windows 7 Professional), and the driver on that one is "Intel(R) G45/G43 Express Chipset."  That machine is unavailable to me, several thousand mi. away.)


#4

The Standard VGA Graphics Adapter is what the system will fal back to if there’s something wrong with your normal driver and only supports very basic functionality. Having looked at AMD’s site, they recommend to get drivers from your laptop’s manufacturer so I think you probably have the most up to date version available.

PVRVFrame runs over the implementation of desktop OpenGL on your machine - have you been able to run other OpenGL applications successfully? We have run PVRVFrame on a 64bit system with an ATI 5870 card without problem. The drivers for the FireGL series can be a few revisions behind, but I would still expect them to show something on the screen.

Ironically, if we’ve had trouble with graphics acceleration in the past then it’s usually been from onboard graphics.


#5

I have actually changed the driver back to the Standard VGA Graphics Adapter by going to Device Manager!ATI MOBILITY FireGL V5250 Properties!Driver [tab]!<Roll Back Driver> [button].  I then tried the demos in C:Imagination TechnologiesPOWERVR SDKOGLES2_WINDOWS_PCEMULATION_2.07.27.0484BinariesDemos under that Standard VGA Graphics Adapter driver and the OS said that it couldn’t run the apps; the same dialog offered to provide details of the failure to run the apps, typically:

 

---

Problem signature:
  Problem Event Name: APPCRASH
  Application Name: OGLES2Water.exe
  Application Version: 0.0.0.0
  Application Timestamp: 4c814dbd
  Fault Module Name: StackHash_5c86
  Fault Module Version: 0.0.0.0
  Fault Module Timestamp: 00000000
  Exception Code: c0000005
  Exception Offset: 00782381
  OS Version: 6.1.7600.2.0.0.256.1
  Locale ID: 1033
  Additional Information 1: 5c86
  Additional Information 2: 5c86b2995e5ecb4d091472c42501f6d2
  Additional Information 3: 2894
  Additional Information 4: 289425cfcfc0a4ff1099144b00ff9e7c

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:Windowssystem32en-USerofflps.txt
---

Unfortunately I never thought to test the imgtec apps using Standard VGA Graphics Adapter as a first line driver, rather than as rolled back to.  But this whole thing is beginning to demoralize me.

#6

Perhaps I wasn’t clear: the Standard VGA Graphics Adapter driver is not going to be able to support our SDK demos.

If you re-install the ATI driver are you able to run any other 3D applications?





#7

Yes.  All of the general OpenGL examples from around wherever run fine.  Both the imgtec emulator and the AMD ES emulator behave in the same fashion on this platform.  I dug up a third emulator from ARM that I’ll probably try (that I’ll have to compile to run, but haven’t yet).

 

But what I'm doing now is I'm about to buy a notebook with Core i7-620M mobile integrated GMA HD graphics.  Hoping everything will run okay on it.

 

Thanks again for your replies.

#8

I hope you have more luck with this notebook. Unfortunately, it’s very difficult for us to investigate your issue since we don’t have hardware that’s even similar to your own. It’s also quite strange that AMD’s emulator doesn’t work either (especially as you’re trying to run on one of their cards…).





As I said before, integrated graphics cards often aren’t very capable for graphics development - they may not be feature-specified enough, for instance.


#9

Hm.  I was hoping that such a late model processor-integrated graphics offering from Intel would accommodate the latest ES and Android development tools.  If just those things will work on the new notebook, that’s fine with me; I mean I don’t game on it or anything.  Too, at this point I fear buying anything more expensive only to discover an emulator still doesn’t run on it.

 

GMA HD on the Arrandale is supposed to support Shader Model 4.0/DirectX 10, as well as OpenGL 2.1.  This will be the first integrated graphics computer I've ever owned, but the price was right and the only time I've heard of an emulator running in my circle was on a new, i.e., bought 4 mos. ago, budget Gateway desktop (with Intel integrated graphics).  (She was describing all of the things she was viewing in the emulator samples to me.)  I'm just trusting Intel's extended that functionality to the mobile die.

 

All I know is that even after going through ATi Mobility Modder last night, the latest Win 7 drivers available to my circa '05-'06 FireGL were still only Dec. 2008.  I'm coming to be convinced that this is a 7 64-bit Catalyst driver issue, and not really a hardware one per se.

#10

It is possible that there is a problem with our emulation, but also possible that it is a driver issue. It’s disappointing that no newer update is available. As you say, the card itself should be fine to be compatible.

If your new GMA HD supports OpenGL 2.1 then, “drivers willing”, it should be fine. We haven’t tested this particular chihpset, however.