Imagination PowerVR SDK Blog

pod/app problems after upgrade from 3.0 to 3.2

pvrshaman

#1

I have an xcode project I’ve been working on since last year using the 3.0 sdk. I upgraded to the latest 3.2 sdk and now the pod files do not load properly. I’m not sure if there was some change that I missed, other than rebuilding and running the app. The pod file will load successfully, however the number of camera’s reports 0. I’m able to build the example app for introducingPOD, which works fine. If I copy the Scene.pod from this example into mine, the same problem exists.



Any thoughts?



Thanks,



Val


#2

Hi Val,



When you open the POD file in PVRShaman, are all of the cameras available? Have you tried inspecting the data in the loaded POD to check there aren’t any bugs in your loading code?



The engineer responsible for the POD exporters and loading code is out of the office this week. I’ll ask him to take a look into the issue when he’s back.



Thanks,

Joe


#3

Hi Joe,



The pod files I have tested, all have cameras. These pod files have been working fine when used with the 3.0 sdk. I even added the sample pod file from IntroductingPOD, which builds and runs fine in the example app, and it to says there’s no camera. It finds the pod file from the main bundle, there’s just got to be some kind of disconnect.



I’m trying to modify the example projects, however everything comes up locked. Can you help me with this? I seem to remember having problems with permissions of the sdk back when I installed it a few years ago. If I can make a few changes to the example projects, maybe I can figure this out.



Thanks,



Val


#4

Hi Val,



Which operating system are you developing on?



The SDK files on your system will have the same permissions as the the installer when it ran. For example, if installing on Linux, the files would be owned by the root user. Accessing the SDK_3.2/ folder permissions through your file explorer GUI or using a command like ‘chown -R’ to change the ownership to your user account should allow you to build the SDK without any issues.



Have you tried opening the POD files in PVRShaman and inspecting the data there? I would advise against using IntroducingPOD, as its not designed to render arbitrary POD files.



Thanks,

Joe


#5

Yes, the pod files look great in PVR Shaman. BTW, I was able to change the permissions.



Here’s the code I use (in all of my projects):



// Get and set the read path for content files

NSString* readPath = [NSString stringWithFormat:@"%@%@", [[NSBundle mainBundle] bundlePath], @"/"];

CPVRTResourceFile::SetReadPath([readPath UTF8String]);



// Get and set the load/release functions for loading external files.

// In the majority of cases the PVRShell will return NULL function pointers implying that

// nothing special is required to load external files.

CPVRTResourceFile::SetLoadReleaseFunctions(NULL,NULL);





// Load the scene

if(m_Scene.ReadFromFile(c_szSceneFile) != PVR_SUCCESS)

{

NSLog(@“ERROR: Couldn’t load the .pod filen”);

return;

}





There has to be some kind of preprocessor macro that I’m missing, some kind of setting, I dunno as I’ve never had a problem opening pod files in xcode projects… If it was a pod data issue, then why does the Scene.pod work in the example program, but not in my xcode project? I mean, the data hasn’t changed. Hmmm…



Val


#6

hello



interesting and what return m_Scene.nNumCamera??



regards

david


#7

This was fixed with the header path setting, which was pointing to the previous release of the SDK. Once this was changed to point to 3.2 the pod file read as before. Thanks for everyone’s help!