Imagination PowerVR SDK Blog

QT PowerVR Driver Load Fail


#1

On a OMAP3530
I added    

-qtlibinfix E
-qt-decoration-styled -plugin-decoration-default -plugin-decoration-windows
-plugin-gfx-transformed -plugin-gfx-qvfb -plugin-gfx-vnc
-plugin-mouse-tslib -qt-mouse-pc -qt-mouse-qvfb
-qt-kbd-tty -qt-kbd-usb -qt-kbd-qvfb
-DQT_KEYPAD_NAVIGATION
-plugin-gfx-powervr -opengl es2 -release -no-cups -no-accessibility -reduce-relocations
                    -shared -no-nas-sound -no-sm -no-nis
                    -qt-gif -system-libjpeg -system-libpng -system-zlib
                    -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2
                    -no-pch -qdbus -stl -glib -phonon -webkit

to the configure parameters and everything seems to build correctly.



When I boot the image I run "export QWS_DISPLAY=powervr"


Then when I run my app i get the following output





powervr: driver not found


Aborted


Qt seems to run fine with just the framebuffer driver and the OpenGL ES demos work just fine too.


Some advice would be greatly appreciated.

#2

Could you build the opengl-es Demo in QT4.5 successfully? I can not.


#3

Could you try to export such a enviroment var:QT_PLUGIN_PATH to your plugin directory?
Thanks!