Imagination PowerVR SDK Blog

Blender 3D to Zappar AR workflow - Help making POD files with textures



Blender 3D to Zappar AR workflow - tutorial request please!

I’m only getting white models in the PVR tools and in Zappar and I need help getting from Blender!
Has anyone been able to successfully model something in blender with UV mapping, export it as a POD from blender, with UV textures and get it to work properly in Zappar? I’m having a rough time learning 3 new apps simultaneously and I need some direction/ help as I’m not sure where I’m missing a step.

It seems simple enough, all I’m trying to do is make a cube with a texture on it…So what am I missing to make this work?

  1. make a cube in blender.
    (I’m assuming my shape making is ok in blender, since I get a white cube to display in shamen & Zappar)

  2. add a logo.jpg to the cube in the appropriate way.
    (I assumed UV mapping - maybe that’s wrong and is why it’s not getting packaged in the POD?? Is there a different way to add logos and textures that would work better for POD/AR?)

  3. “Bake” the texture into an image.
    (I got blender to render an image of the cube with the texture, but it’s blank white in shamen and Zapper. Is baking not the right thing? I saved the UV painting to a png, jpg & tiff…still just white in shamen & zappar.)

  4. Export said textured cube and material image from blender in such a way that zappar will see it.
    (how do I make a POD file with textures still intact? First I tried the POD plugin from blender. Then I tried fbx, obj & dae from blender into shamen. Still white. )

  5. import the cube into zappar or shamen (I can only ever get a white model, never any textures! Shamen won’t even recognize that there is a material associated with it. Is that a problem with my export or am I missing an import step?)

I’m not even sure what to try next or from what app…if anyone has had success in Blender to Zappar workflow, please chime in :slight_smile:


I’m Daniel, Customer Success Manager at Zappar.

This question was posted in the ZapWorks Forum and the answer can be found in this post:

Hope that helps!