Imagination PowerVR SDK Blog

NOOB nightmare. No textures displayed correctly in any new models.




I’m new to the forum and pretty inexperienced in all aspects of 3d software (great start I know)

I’ve been making all sorts of models in Blender, mainly using it to simplify 3d scans made with 123dCatch from Autodesk. I’ve happily made many fbx, dae, and obj files of various complexities. Generally that’s worked quite well.

I now need to convert these files to .pod to be used in the AR app Zappar.

A couple of months ago i experimented with converting a few files and they all showed up well in Pvrshaman and Zappar. However trying the same thing again today with a wide variety of models i havent been able to get a single model to show in shaman or any other program with the correct textures. They are all completely grey or white with some weird smudges of colour.
My previously converted models still open and display correctly.

I have taken instructions from the Zappar documentation to get the right settings.


[i]The “Geometry” tab of the export options window controls how the object data is exported. For Zappar, the primitive type should be set to “Indexed Triangle List” and the “Use Custom Optimization Settings” checkbox can be unticked. These should be the default settings.

The lower portion of the Geometry panel allows selection of the vertex data that is to be exported. The default settings should also be suitable for use in ZapWorks Studio. The “Position” and “Normal” rows should be enabled with the data type set to “float”, and have the 3 channels set to “X”, “Y”, “Z” in order. “Export Mapping Channels” should also be ticked, which should also be set to “float” data type and have the channels set to “U”, “V”, and “-” in order.

On the “Materials” tab, the main “Export Materials” checkbox should be ticked.[/i]

There are no animations or other complexities.

Can anyone point me in the right direction?

I’ve tried converting obj, fbx and dae files. I’ve tried exporting the file to various locations with various versions of the texture files. I’ve tried various combinations of other settings and can’t get anything to work.

Any help would be vastly appreciated. I know it’s difficult to help someone with limited knowledge!



(on another note - I cant get the flipping plugin for blender to work. I’ve copied the files to the directory as per the manual. I’ve also tried ‘install from file’ from within blender. Im using the correct x64 files but always get a winerror 126)


Hi Andy,

Firstly, welcome to our forum. We will try to help you as much as we can.

The problem exporting models for Zappar might be related to the vertex attributes configuration. Sadly, it is very easy to change the configuration by mistake when scrolling the window. This is something we have fixed for our next release.

Try loading the default configuration. Just right-click on the left hand panel “Default config” and select Set as Current. The default configuration should work with Zappar.

If this does not work for you, please attach one of the broken models to this thread and we will have a look.

The problem with Blender on Windows might related to the location of the QT libraries required for our plugin. These should be installed in the same folder where the Blender executable is (C:\Program Files\Blender Foundation\Blender). Do not forget to also copy the “platforms” folder in the same place. Our documentation is not very clear about this.
If you still having problems with this, please, let me know.

Best regards.



Hey Carlos

Thank you so much for your reply.

I’ve followed your instructions and now the Blender Plugin works well. You’re right though, the documentation really isn’t clear on how to install it.

As for the models. I’m not totally sure what’s going on but they seem to work on the whole. I still have problems with some models - but I think that might be Blender issues and not Pod issues.

I’m not sure if it was the default settings that have sorted things out. I also changed from using the 64 bit version of Shaman to the 32 bit, but that’s unlikely to have helped I’m assuming?

Anyway. I’m back on track I think.




Hi Andy,

I am glad that things are ok for you now (more or less :).
Don’t hesitate to contact us if you require more help.