Imagination PowerVR SDK Blog

Can't export animated character from Maya



I am trying to create a simple animated character in Maya that I can export as a pod file using the PowerVR exporter.  I am able to export the geometry of the character successfully, however the character does not appear to have any animation.

The character is a simple set of polygonal cubes parented to a main cube and then the whole thing is rigidly skinned to a skeletal system, which contains a simple 1 second animation.

I am using Maya 2010 and PVRGeoPOD v1.25 on Mac OS X 10.6.8

What can I do to figure out how to successfully export this animated character?


What are you selecting when you export? When I need to export a rig, it’s normally required to select the mesh along with the joints that are skinned to the mesh. You can also try baking the animation to the joints. Also, sometimes it may be required to select the animation nodes attached to the joints. Select the joints and run:

$all = listConnections;

select -add $all;

Hope any of this helps.



My scene is pretty simple since I created from scratch explicitly for testing animation exporting.  Thus, all it contained were meshes and the joints they were skinned to.

How does someone bake animation to the joints in Maya?  I’ve never done that before.


Well in my tests it seems like selecting the geo and then selecting the joints next seem to work. Though other times it seems like it doesn’t work. Baking animation onto joints is normally used for animation on joints where something is driving them (like IK or dynamics). But it might solve unknown problems. Go to edit --> keys --> and then open the bake simulation option box and adjust the appropriate attributes. You need to have the joints selected that you want to bake the animation to. This basically creates a keyframe for every frame down the timeline. Then select the geo and then the joints. I’ve found that sometimes the animation doesn’t go through unless you have the keyframe animation nodes selected as well.

Good luck.



I believe I’m following everything that was suggested.  I was able to bake the animation and I think I selected everything and executed the MEL commands to incorporated the animation nodes, however nothing seems to be making a difference.  No matter what happers PVRShaman will load in the model and nothing animates
I tried Export Selection… and Export All…


How is the history on your meshes? I’ve noticed that shaman doesn’t really like extra nodes attached to the geometry. I’ve also ran the optimize scene commands before and magically things started working again. It’s best to make sure the scene is as clean as possible though I assume not much is going on in your scene since its so simple.


I am in the habit of freezing transforms and deleting history on all my meshes before trying to export, so that has already been done.  I’m not sure I’m familiar with the optimize scene commands.  How does someone optimize a Maya scene?


Under the file menu there is a command called optimize scene. Just open up the option box and see all of the options. Basically what it does is delete out random nodes in different categories that have lost connections along the way and in so doing, it helps to clean up the scene and make it smaller depending on how many nodes there are. Just be careful when using it. Every blue moon it may break something but all you need to do is just use undo.


I tried optimizing the scene and that did not help.

I did try creating a different scene, and I got rather different results, which are also not what I wanted.  Here is what I did

Created a polygonal cylinder centered at the origin.

Rotated the cylinder 90 degrees around the X axis

Scaled the cylinder by a factor of 5 along the Y axis (i.e. its height)

Set the height segments to 10

Froze transforms

Deleted history

Created a skeletal system with 3 joints; the first joint was at (0,0,6), second joint at (0,0,0), third joint at (0,0,-6), so basically the bones for the joints ran through the length of the cylinder

Selected the cylinder then selected the joints, and performed a smooth skin binding

Key framed the center joint, located at the origin, so it was at its default 0 rotation value for the first and last frames (frames 1 and 24)

Key framed the center joint rotated by -45 degrees around the Z axis at frame 12

This created an animation that caused the cylinder to bend and unbend around its center.

I then tried exporting this scene with PVRGeoPod exporter.  Lading this scene into PVRShaman produced a scene with no geometry even though cylinder was object was listed the left pane of the application.  This was different from my other export where I was able to see all the geometry.  Obviously since I couldn’t see any geometry, I couldn’t tell if anything would animate.

I tried exporting the Maya scene again this time using the OpenCOLLADA exporter to create a .dae file.  I was able to import that .dae file into Blender and verified that it looked and animated correctly.

As a side note, I had also tried to my original scene to .dae.  When I loaded that into Blender I got the geometry and the skeletal system.  However the scene did not animated correctly as the joints rotated in the wrong direction and they did not animate the geometry at all.

Anyway, after verifying that it looked like the .dae file for the cylinder was correct.  I tried using the Collada2PODGUI application.  When I loaded this pod file into PVRShaman, I could see the cylinder only it looked slightly distorted as it was not completely circular.  It also animated, however in a totally bizarre and incorrect way.  This was the closest I had come to getting some to work.  I’m not sure why these export tools do not seem to be able to handle such as simple scene.  It seems they would work better than this.

I’m not sure why these scenes are not work, and what it will take to successfully export them.  I could provide copies of both scene, if someone  is interested in looking at them.  They are pretty simple, and I basically described how to create the second scene from scratch if someone wants to just follow the steps listed above and see how things work for them.


Hi Thomas,

Sorry your having these on going problems. Might I suggest you send the scene files and the POD files in question to us at That way we can debug them here and try to work out whats going on.

If the files are too big to send via email, simply upload them somewhere and send us the link.

Bob Gardner

Developer Technology Engineer

Imagination Technologies.


Thanks Bob.  The scene are really so file are quite small, about 100 Kilobytes each, so I should be able to send them in email.


I swear I had this problem solved months ago. I’ve gotten to the point where I wanted to add animation to the project I’m working on. I tried animating a character and exporting it, and nothing animates.

I tried creating a simple animated cylinder like what I described in an early posting on this thread. That won’t animate anymore either. I can see that cylinder in PVRShaman, and nothing animates when I initiate playback.

I am not sure why. I’ve kept all my export settings and haven’t changed them for months. I thought with these settings I was set and everything would just work.

Again I am trying to export animation from Maya 2010 running on Mac OS X 10.7.5. using version 1.25 of  the PVRGeoPOD_v2010 plug-in.

What advice can people offer for getting the animation to export.


I installed the latest PowerVR SDK, which has much better tools for the Macintosh than the older version, and I was able to get the export to work. It is still kind of tricky. Someone has to make sure the select everything in the mesh and all the bones. It is not good enough to just select the root bone, even though all the bones may look selected in Maya. Someone has go through and select each individual bone, which is kind of inconvenient, however the animation should export.



Sorry for the delayed response. I’m glad to hear that you’ve found a solution to your problem. Let us know if you encounter any other issues.