Imagination PowerVR SDK Blog

Drivers for Mistral OMAP 35x EVM boards


#1

We’ve got one of these boards and I can’t find the GLES driver files. We’ve had zoom boards before and these files have come from TI but for the life of me I can’t find the files for this board on the company website so I was wondering if…

A) Anyone else has one of the boards and can tell me were you got your drivers from

or

b) If I can get them direct from ImgTech??

Many thanks,
Richard e Collins.


#2
Richard, The Graphics SDK is at,

 

http://software-dl.ti.com/dsps/forms/export.html?prod_no=OMAP35x_Graphics_SDK_setuplinux_3_00_00_08_update.bin

 

And the Getting Started Guide at,

 

http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/S1SDKLNX/DVSDK_OMAP3530/exports/OMAP35x_Graphics_SDK_GettingStartedGuide.pdf

 


The OMAP3530 updates (including DVSDK) will henceforth be available at,


http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/S1SDKLNX/DVSDK_OMAP3530/index_FDS.html

 

~prabindh,TI

#3

Many thanks but the first link just takes me to a form for ordering DSP stuff??

 There was a link on their product page but that link was broken a pointed to an incorrect file. I found a link that did work after googling for the file name. But the driver install did not work until I created an empty file on the target file system. Not when I try to start the drivers modprobe failes to find it’s dependancy file. I need to make sure the kernel matches the filesystem before I move forward. Looking at the downloads I have I 've got ‘OMAP35x_Graphics_SDK_setuplinux_3_00_00_06.bin’ so could explain why the driver is not working on the system. [scatches head].

I’ve done this before with zoom1 and zoom2 no problems, just seems the downloads for this board a little broken. Although saying that the Andriod build they do worked first time.

I feel these systems are better used by Linux pros, which i’m sadly not.



#4

The first form is actually part of a registration process, please update your details and make the request. If you still have issues, send me a message.


#5

Richard - were you able to get the .08 version drivers ?


#6

Yes, they also now come with them already installed into the nfs file system, which is handy. The problem now is that my kernel is incorrect. I’ve got a 2.6.22.18 kernel and so modprobe fails. (I’m guessing a bit here that it is a kernel version  issue)

Some more digging about to do. :slight_smile:


#7

I’ve got it working now using the file system from the 1.0.2 SDk and installing the drivers on that. :slight_smile: Seems I could not find a kernel to match the nfs files system that was in the 3_00_00_08 Graphics SDK. No big deal now it works.