Imagination PowerVR SDK Blog

I can't make the latest PVRGeoPOD (from SDK v3.1) work with the latest Blender (v2.68a)

pvrgeopod

#1

Both just freshly installed, and this is the result:



Read new prefs: C:UserspaulAppDataRoamingBlender FoundationBlender2.68configuserpref.blend

found bundled python: C:Program Files (x86)Blender FoundationBlender2.68python

read blend: C:UserspaulDocumentsiToBMineMine.blend

Determined we’re running on Windows

Attempting to load library: C:Program Files (x86)Blender FoundationBlender2.68scriptsaddonsPVRGeoPOD.dll

Traceback (most recent call last):

File “C:Program Files (x86)Blender FoundationBlender2.68scriptsaddonsPVRGeoPODScript.py”, line 824, in execute

return DoExport(context, self.filepath, pvrgeopod)

File “C:Program Files (x86)Blender FoundationBlender2.68scriptsaddonsPVRGeoPODScript.py”, line 784, in DoExport

if not pvrgeopod.loadLibrary():

File “C:Program Files (x86)Blender FoundationBlender2.68scriptsaddonsPVRGeoPODScript.py”, line 83, in loadLibrary

self.lib = cdll.LoadLibrary(libpath)

File “C:Program Files (x86)Blender FoundationBlender2.68pythonlibctypes__init__.py”, line 431, in LoadLibrary

return self.dlltype(name)

File "C:Program Files (x86)Blender FoundationBlender2.68pythonlibctypes__init
_.py", line 353, in init

self._handle = _dlopen(self._name, mode)

OSError: [WinError 193] %1 is not a valid Win32 application



location: :-1



location: :-1




That was from using the 32bit version of the addon with the 32bit version of Blender. If I use the 64bit versions of both, I get an error to do with an entry point missing from QtGui4.dll.



Please, any advice most welcomed. This is completely stalling my game development.



Cheers,

Paul.


#2

Hi,



The 3.1 version of the exporter worked fine for me with Blender 2.68a.



Based on the error you are seeing it looks like you are using the 64-bit version of PVRGeoPOD.dll with the 32-bit version of Blender. Maybe try setting up PVRGeoPOD again.



Thanks,



Scott


#3

Thanks for getting back to me. I suspected that myself, so just in case I tried both versions one after the other. I’ve also tried both the 32bit and 64bit versions of Blender. Admittedly the 64bit version (of both Blender and plugin) failed in a different way, as though it was able to accept the main dll, but then failed finding an entry point in one of the Qt dlls.



Both my PVRGeoPOD.dlls are dated 20 June 2013 15:51:42. The 64bit one is 1,661,440bytes and the 32bit one is 1,546,752bytes. Does that concur with your version. Which do you use: 32bit or 64bit?


#4

I just tried the 64bit versions of both again. The error I get is The procedure entry point ?heightForWidth@QTabWidget@@UEBAHH@Z could not be located in the dynamic link library QtGui4.dll


#5

I have the 64bit version working now. It looks like the installation instructions are slightly incorrect. The Qt dlls need to be placed in the main Blender directory, rather than in with the addons.



AFAIKS, the 32bit version is truly broken in some way.



I no longer need help with this issue, but I’m happy to do more tests on the 32bit version if it would help to track down the remaining problems.


#6

Glad you got it working and cheers for pointing out the mistake in the documentation. We’ll get that fixed for the next release.


#7

Thanks for posting the fix Glidos. I also had this problem. Works with the RC of Blender 2.69 as well.