Imagination PowerVR SDK Blog

Point particles not working in the new SDK

pvrvframe

#1

Hi,



I have upgraded to SDK 3.1 and observed that my [textured] point particles stopped working. Somehow only when texture2D is used as below this seems to happen, because if I use particleColor alone the particle quads appear. Note, my texture is needed to apply alpha and blend these together.



gl_FragColor = texture2D(sParticleTex, gl_PointCoord) * particleColor;





Swapping to the old dll’s of libGLESv2.dll (I am using X86_32 ) restores the textured point particles to work again.





Thanks,

Madan


#2

Hi Mkandula,



Thanks for reporting this. Did you upgrade from 2.9 to 3.1? I ask because it looks as though this bug has been around since SDK 3.0! In any case I have found the issue and it will be fixed in the next release and you’ll be able to see your point sprites again. Apologies for the inconvenience in the meantime.


#3

Hi Chris,

Yes the old dll’s were pre 3.0 SDK.

Thanks for looking into this !!


#4

Hi,



When will the SDK with this fix be released ?


#5

Hi Madan,



Our latest version of the 3.1 SDK went live a few weeks ago. You can use the installer on our download page to obtain the new packages.



Thanks,

Joe


#6

I installed the new SDK, but the point particles are still not working !


#7

Hi Madan, sorry for the confusion. This particular bugfix didn’t make it into the 3.1R2 release but will be fixed in the next major version (3.2) which we should be getting out in the next month or so if all goes to plan! Thanks for your patience :slight_smile:


#8

Hi Chris, I am currently using 3.2 SDK. In the PC emulation, I am still not seeing point particles working.

Can you please provide some interim dll that might work ? I have been having this problem since close to 1 year !!


#9

Hi,



if you sign up for our Developer Support portal and file a ticket requesting access to our 3.3 SDK closed beta, I can give you access to the latest version of PVRVFrame.



Regards,

Joe