PowerVR SDK 1.1 issue on Linux

 I am trying to link my application with PowerVR OpenGL ES 1.1 SDK for Linux emulation. I am running Ubuntu 8 in a virtualized environment.  After I link the source with libGLES_CM, I get a page segmentation fault. Does it has anything to do with virtualized environment or there is some other problem? I have made sure to install the following packages:

sudo apt-get install libglut3-dev -y
sudo apt-get install libglew-dev -y
sudo apt-get install glew-utils -y

Even if I run the very first demo “01_Initialization”, the window appears for a short duration. The screen changes different colors and then application terminates. It seems to me that something is nor right. The same demo when run on Windows, keeps the window visible as the background changes to different colors. I think same should happen with Linux as well, but here the windows just disappears after a couple of seconds and application terminates.

Ran into the same issue on both Ubuntu 9.10 and 8.04 in a native environment (ie. not virtualized). My hardware features an Intel Centrino Duo with an ATI Radeon x1600 Mobility. Backtrace shows a segfault in strcat called from glGetString. Did you fix this problem?

Well I could not resolve that issue as it was produced in a virtualized environment. Also, PowerVR guys do not recommend using their SDK in a virtual environment. So there was no other way to deal with that. Things worked all right on a separate system where there was NVIDIA GPU and the setup was not virtual.

Regarding your case, there may be a way to deal with as you are not in a virtual environment. Now it seems that glGetString() is misbehaving or something else may be wrong. Have you checked the system capabilities using glxinfo? Have you been able to run anything else related to OpenGL ES on your system? I would suggest try to run the sample demos from Imagination that come with the SDK. Also, stick with Ubuntu 8.04 first and try to resolve the issue. Once it is done, then move onto the 9.10. It is very much possible that 9.10 being a relatively newer release as compared to 8.04 may have some other issues as well. Do let me know what the output of glxinfo is on your system. Thanks.

J R Shah