Imagination PowerVR SDK Blog

Problems Installing PowerVR SDK for Linux 64 on Linux Mint 15

pvrscope

#1

Hello,



I asked this in another related string, but thought that I should perhaps start a new string too.



I followed all of the instructions in previous and strongly related discussion string where a person’s problems had been solved and could not get the install to work.



When I try to run:

sudo sh ./PowerVRSDKSetup-3.1.run-x64



I get:

./PowerVRSDKSetup-3.1.run-x64: 1: ./PowerVRSDKSetup-3.1.run-x64: Syntax error: “(” unexpected



Please advise and thanks in advance,

Thom


#2

Hi Twives.



Just to let you know, we’re looking in to this for you, to see if we can find the root cause, and a work around for you.



In the short term, are you able to install the 32-bit version?



Bob.



PS. Glad you liked getting the Commenting badge and the welcome message :wink:


#3

Hi,



I think you are trying to execute the installer as a script instead of a binary. I usually just:



chmod +x PowerVRSDKSetup-3.1.run-x64

sudo ./PowerVRSDKSetup-3.1.run-x64




Notice that I do not use bash, sh or any other shell.



Cheers,

Guillem


#4

GuillemV, I had changed to executable, but I am newb enough to have not thought to run it without “sh” - it is installing now - thanks!


#5

I spoke too soon - During install, I have the following problem. The Dialog box says:

Error Unable to download component PVRScope: Component file version does not match

Then it wants to exit the installation program. I think it may be a proxy issue, but I am not sure yet.

#6

Hi,



Have you had any luck downloading the package yet, or are you still hitting this error?



Thanks,

Joe


#7

I ran sudo ./PowerVRSDKSetup-3.1.run-x64 and went through all the setup questions with the minimally suggested options, and I also set up the proxy for my company. On component 3 / 42 (42 - that’s funny - didn’t notice that before), it says: Unable to download component PVRScope: Component file version does not match. I am on Linux Mint 15 and I am up to date on updates.


#8

Strange. Can you share the details of the selection you’ve made during installation, i.e. selected packages, target API & target OS?



Thanks,

Joe