Imagination PowerVR SDK Blog

Can not install PowerVRSDK 3.1 (64 bit) on Ubuntu


#1

Put simply the installer will not run. When I try to run it, it says command not found. How do we install the latest version of PowerVRSDK on ubuntu?


#2

Hi,



Can you try using “chmod a+x” on the installer binary, then running it again? If this fails, I’ll get the engineer responsible for the installer to look into it.



Regards,

Joe


#3

Same result.


#4

Which SDK installer are you using? The latest Linux 64-bit binary from our download page?



Regards,

Joe


#5

I’ve been trying the 64-bit.


#6

Hmm… I’ve just tried running the 64-bit installer on another computer running Ubuntu and it’s working. The problem might be on the system itself.


#7

Ah, ok. Good to know its working on another machine :slight_smile:



What CPU is in the failing machine? Are there any network restrictions on that machine that may prevent the installer contacting our servers?



Regards,

Joe


#8

There are no network restrictions on the computer that’s failing (It’s my own desktop). It has an amd cpu, I’m not sure on the exact one (I’m currently at work and do not have access to the machine).


#9

Are you launching the installer remotely? The installer GUI relies on X11 (or whatever windowing framework is available on your Linux machine). If there is no windowing framework available or the window cannot be created from your remote session, this may explain why the application is exiting immediately.



Regards,

Joe



#10

Nope, I’m not doing it remotely. The application is not even launching on the machine. It says “command not found” when I do.


#11

So, the failing machine is using a windowing system?



Regards,

Joe


#12

Yes. It uses X11.


#13

Hi,



Please notice that we target Ubuntu 12.04 LTS, any other system may or may not have been tested. Having said that, which version of Ubuntu are you using? Have you tried to run the installer with “sudo” or as root (“sudo su”)?



Cheers,

Guillem