Imagination PowerVR SDK Blog

PVRFRAME set to 60FPS?

pvrvframe

#1

Dear all,

 

I use Windows PowerVR SDK emulating OpengGL ES2.0 under Windows 7 x64.

 

I develop my application, and while I debug it, the PVRFRAME displays, the graphics gets refreshed on stable 60 FPS, regardless of what content I display.


Is it possible to unlock this constant loop (60 FPS)?. I controll the frame refresh speed in my refresh loop, but I need to see the actual maximum FPS with the conted displayed at particular moment.

 

I know for sure that for couple of weeks the FPS was running pretty high (1700 FPS) on testcube, but I do not know what I did, that the refresh rate is again limited.

 

PowerVR SDK version used: OGLES2_WINDOWS_PCEMULATION_2.06.26.0649

 

Thank you.

Regards.

 

 

#2

Your application is being v-sync limited. To disable this you need to call glSwapInterval() with a value of 0.
If you are using the PVRShell then you can use a line like

Code:
PVRShellSet(prefSwapInterval,0);

in the InitApplication function.

If this doesn't help then it's also possible that a driver setting on your system is forcing v-sync as the emulation uses your machine's OpenGL implementation to render.

Please note that performance on PVRVFrame is not a good indicator of performance on a POWERVR device as there are some areas in the emulation that incur a software overhead and the underlying acceleration on your system will have a significantly different rendering architecture.


#3

Dear Gordon,

 

Thank you for good quality response.

 

As you predicted, the solution was in my driver settings. I had to disable Vertical Sync in my NVIDIA Control Pannel settings.

 

I went to: NVIDIA Control Panel -> 3D Settings -> Manage 3D Settings -> Global Settings -> Vertical Sync -> Force off.

 

DirectX Version: 11.0

Driver Version: 258.96

 

Best regards.