Performance issues after updating HW/powervr sdk

We are using a 3rd party tool to create a 2d menuing system. We develope the application on the PC using powerVR 2.10 and our gpu is nvidia quadro FX3700. We got new PCs, and the new hardware is nvidia quadro K3100M (driver version 332.76). Our application would not work using the 2.10 sdk, so we updated to 3.4 powerVR sdk. Our application now runs, but the call to the third party software that initializes and compiles the shaders takes over a minute and half to complete. I spoke with the 3rd party vendor, and they feel that there might be some settings in the emulator that may speed up compilation. I am not really familiar with the emulator other than we use it for pc development. I was not part of getting the original application running using the 2.10 version, and seem at a loss. Any assistance you can offer would be greatly appreciated.

Hi Susan,

We’re not aware of a shader compilation performance regression in our emulator. PVRVFrame verifies GLSL ES shaders are valid, converts them to GLSL shaders and passes them to the host OpenGL driver for compilation. The verification and conversion process is light-weight, but it’s possible performance has regressed here.

Have you been able to test the 3.4 SDK version of PVRVFrame on your old machine or run the 2.10 version on your new machine to directly compare compilation performance? Are you using the same version of the 3rd party tool on both machines?

If you can share a binary with us that reproduces the issue, we can investigate. If you would like to share such a binary with us confidentially, you can attach it to a ticket in our support portal:


Thank you for your response.

I am using the same 3rd party software on both machines. Running the different sdks on opposite machines results in exceptions being thrown. Using the OGLES2HelloAPI_Windows as the test program, when I run the 3.4 sdk on the desktop, the call in CreateEGLDisplay to eglMakeCurrent throws an exception. When i run the 2.10 sdk on the laptop, the call in SetupEGLContext to eglGetDisplay throws an exception.

I will try to get a binary to you tomorrow.

Thank you !


That driver version looks quite old, could you update your Nvidia drivers, try again and we’ll see if that makes a difference?

The laptop machine (the one I need to get working) has the latest driver. I know the desktop has an old driver, but that doesn’t matter to me because, while it does work with the 2.10 sdk, the machine is being obsoleted at my company and we are transitioning to the laptops. The device I have trouble with is the nvidia quadro K3100M (driver version 332.76), running with the 3.4 sdk. Let me know if you think I am mistaken. Thank you.

I opened a ticket today about this and included binaries and the main program where the power vr environment is being initialized. I forgot to mention that I build this using microsoft visual studio 10.0.40219.1 sp1.

Paul - I thought I had the latest driver but you were right. I updated it to 347.88, which I think is now the latest. However, the issue still remains. - Susan