Imagination PowerVR SDK Blog

pvrhub install fails: INSTALL_PARSE_FAILED_NO_CERTIFICATES

pvrhub

#1

adb.exe install PVRHub.apk fails with INSTALL_PARSE_FAILED_NO_CERTIFICATES error.

Android version: 4.2.1
Android SDK platform tools revision: 23

Is there everything ok and up-to-date with pvrhub certificate?


#2

Hi Anatoly,

Is this the latest version of PVRHub from the 3.5 SDK?

I’ll check with the PVRHub lead and will get back to you.


#3
  Yes, it is latest 3.5 SDK.

#4

The PVRHub lead said that he’s seen this error before when a new version of the tool is installed over an old version already installed on the device.

If you already have a version of PVRHub installed, can you uninstall it before installing the 3.5 version of the tool?


#5
 Alas, doesn't seems to be this issues. There is no any other versions of PVRHub on my device.
                  Thanks for fast response!

#6

Sorry to hear that didn’t resolve the issue. A few more questions:
[ul]Which device are to attempting to install PVRHub to?[/ul]
[ul]What version of Android is the device running?[/ul]


#7

Device: ASUS Transformer Pad TF700T
Android Version: 4.2.1

I’ve checked another device: Samsung Galaxy S4 with Android 4.4.2 and PVRHub was installed successfully.

BTW, I hope email notification is still working cause I got no email on last reply…


#8

Hi Anatoly,

Apologies for the delayed response. I’ve filed BRN57879 in our tracker for this issue as PVRHub should work on Jellybean and newer devices (as stated in section 2.1 of our user manual).


#9

Hi Anatoly,

The PVRHub lead engineer has identified an issue with JDK signing that he believes is the cause of this problem. We’ve fixed the issue for our upcoming 4.0 SDK.


#10
   Hi, Joe!

PVRHub.apk installation works fine with SDK 4.0. Thanks for fix.


#11

Perfect. Glad to hear it’s working now :slight_smile: