Imagination PowerVR SDK Blog

Unable to run prebuilt or compiled OpenGL program


#1

I am working on Pandaboard with omap4 platform. The Imagination driver is installed. I copied the SDK prebuilt sample program OGLES2HelloAPI to the board and tried to run it, but I got this error:



$ ./OGLES2HelloAPI

-bash: ./OGLES2HelloAPI: No such file or directory

$ file ./OGLES2HelloAPI

./OGLES2HelloAPI: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.16, not stripped



Is there anything wrong? I managed to compile on the host PC but the same program can not run either.


#2

Hi,



I’ve not seen this problem before. When you say you compiled on your host machine, do you mean you cross-compiled for ARM and tried that binary on your Pandaboard, or do you mean you’ve seen the same problem on your host machine? What OS and CPU architecture is your host machine (e.g. Linux x86)?



Thanks,

Joe


#3

I am using pandaboard. The prebuilt linux samples would not run. I did not bother to use the cross compiler as that does not work either. I finally setup the board so that I can just compile on the device. It worked now.


#4

Could it possibly be a permissions problem with the prebuilt binaries? Have you tried running: chmod a+x OGLES2HelloAPI

./OGLES2HelloAPI




Glad to hear you’re able to build it now :slight_smile:



Thanks,

Joe


#5

chmod would not help. It is executable. The file itself does not seem to be right.


#6

Is your Pandaboard image built for armhf (hard-float)? The binaries in our SDK are for soft-float. This may explain why the compiler on your Panda is able to create a working binary.



In our 3.0 SDK, we provide soft-float and hard-float binaries of PVRPerfServer. As a quick test, you could try running both and see which one works and which one fails.



Thanks,

Joe


#7

Yes you are right. PVRPerfServer armhf version works.