Invalid dimensions selected for your chosen format.Please see -help for valid parameters.

PVRTexToolCLI -i E:\bin\res\view\atlas\public\buff_icon.png -f ASTC_6X6 -q astcveryfast -p -o E:\bin\res\view\atlas\public\buff_icon.ktx

What am I doing wrong with the following commands?

Hi simonastcask,

Thanks for your message, and welcome to the PVR Developer Forum!

I tried your PVRTexToolCLI command with a screenshot I took from my screen and it worked fine
PVRTexToolCLI -i sample.png -f ASTC_6X6 -q astcveryfast -p -o sample.ktx

Please check the path to the file you want to convert buff_icon.png and also try updating to the latest version of PVRTexTool from our Developer Portal (please note that you need to create a new account in order to access the Downloads section).

Let us know if there are any issues after those steps.

Best regards,

thanks for your response,i tried that cli cant work with 128x128 size pictures,but gui tool can,ASTC_6X6…

ver2020R1 still work well but not after ver2020R1

Hi simonastcask,

Thanks for your message.

If you have an example .png picture that is not working with PVRTexToolCLI when converting it to ASTC 6x6, please attach the picture in a message. We will try to reproduce the problem and fix it.

Best regards,


Hi simonastcask,

I was able to reproduce the issue you’re having, I have reported it to the Tools Team. I will inform you once it is reviewed.

Best regards,

I have the same error when I compress a texture (640*662) using ver2020R2.

However it works fine in ver1.6.

Maybe the reason is ASTC encoding has been built in texlib since 2020R2?

Hi ShengyuDu,

Thank you for your post and welcome to the PVR developer forum!

After discussing with the Tools Team, they have informed me that there is a fix for this issue.

We can provide you with an internal version of PVRTexTool with the issue fixed. You just need to request it through our support portal ( Also please specify the Operating System you’re using.

Kind regards,


Hi stephen,

Thank you very much for helping!
And I want to know whether this issue will be fixed in ver 2022R1?

Best Regrads