Imagination PowerVR SDK Blog

Model Error?



Hi guys not too sure if this is the right place to post this but here goes (please move it mods if its wrong thanks Smile )

Ok so now the game I have been working on is now into model loading stage, my programmer has chose to use the .pod format for our iPodTouch / iPhone platform game but the model I have exported is giving him error from the glDrawelemet I have no idea whats wrong please help in anyway, below are a few approaches I have tried

1. Normal mesh, skinned and exported, I think due to the 8 bone limit per mesh for the .POD format causes the mesh not to follow the bone animation (No errors, except for mesh not following)

2. Broken up mesh(1 Color = 1 Mesh), as in the image posted below. (so each mesh only has less than 8 bones controling it) This causes the glDrawelemet problem, even after I closed all the "holes" in the mesh and mannualy triangulated the mesh.

I am guessing that the .POD format doesn't export more than X amount of meshes in each file, X refers to a number. (I hope you understand, I don't really understand what I typed also lol)

I am pretty much dry of ideas on how to solve it. I tested the above approach with a much simpler cylinder model and it seemed to work.

Thanks in advance, for any help =)

xiaobaizhu2009-05-20 05:19:06




Could you give us more information on the type of error you getting? Was the .pod generated from Max, Maya or Collada2POD? Also, what export options are you using? If you would like you can send your .pod and max/maya/collada scene to and we'll take a look.






Hi, thanks for the speedy reply

Error report (Updated)
Prompt - Program received signal:  "EXC_BAD_ACCESS".
Image below

I have no idea how it works, so ya I only hope it helps XD

I am using the 3DsMax2009 .POD exporter
Below is the attached screeny of my settings

Will send the files to the attached email, but do keep it private. Thanks =)

If there's anything else you need do let me know.

xiaobaizhu2009-05-20 17:48:00


Hi guys, the problem has been solved.

.POD is quite sensitive to how the information in the mesh and skin is created, I find, resetting your mesh and removing all skin related modifiers, re skin them and it should work just fine.

I hope my head banging saved you from your head banging.


xiaobaizhu2009-05-21 03:54:55




We are glad you solved the problem. Of course we will keep complete confidentiality of your data but, if it makes you fill better, we can sign an NDA between the two companies.


I run the POD file you sent us and it run without problems in PVRShaman so the original POD file generated was correct. This might mean that you were exporting 4 bones per vertex which are not supported by OGLES1: OGLES1 supports 3 bones per vertex unless you have an extension to support 4.

Possibly your reskinning reduced the number of bones per vertex fixing the problem.

By the way, you do not have to use float for the matrices weight. A byte per matrix should suffice and will reduce your total geometry data.


Best regards.




Thanks for the re-assurance, we should be fine without the NDA =)

And yup, its probably an compatibility issue with the OpenGL versions, not really a programmer so just happy its working lol.

As for float matrix, I not too sure what it means, care to elaborate? If its regarding code, I will pass on the info on to my programmer if not would love to know how to optimize my model even more!

Thanks for all the help,



I think Carlos is referring to the vertex vector format and the corrsponding box in the exporter where your screenshot shows that you’re using a float value for the Bone weights value. You could reduce the total size of your vertex information by changing this to byte and potentially help performance.