Imagination PowerVR SDK Blog

some techs that POD doesn't support?



Hi, I have searched a lot threads about POD format model, but there’s probably no standard method to make a skinned animation model for POD uses. are there some techs that we cannot use for skinned model?

My group made a 3dsmax skinned model using biped skeleton animation, but the animation of the exported pod file is incorrect. Some vertices are ‘flying’, and the first frame is not that one in 3dsmax, it just looks like it’s not affected by the skeleton, but the animation did play in the loop.

Any help would be appreciated, thanks!


There are some known limitations to the exporters and Collada2POD (such as only supporting linear animation - no splines), which are highlighted in the corresponding documentation.

What version of the SDK are you using? If you send us a copy of your original model, a screen-shot of the exporter settings you used and the broken POD model, we can look into this for you. Either post links to these files in a post if you don’t mind them being public, or email them to for us to look at


Hi Joe,

I’ve sent them to your email


li9s wrote:
Hi Joe,

I've sent them to your email


Hi, thanks for your files. The problems you're experiencing are due to a combination of a bug in the exporter and a limitation in the POD format. The limitation is that position, rotation and scale are insufficient for representing the bone transformations of your character. The way to work around this is to tick the 'export matrices' option in the exporter which will export the transformations as matrices that contain all the needed information. As for the bug in the exporter the problem is due to it not taking into account that your animation starts at frame 100 instead of frame 0. This will be fixed in a future release but in the meantime if you export your animations from frame 0 your scene should export correctly. 
Scott2011-03-24 17:13:03



I have a similar problem although I’m unable to debug it properly.

I have a 3d-model I bought online ( which was delivered in several different formats, one which was Collada.

When I ran the model through Collada2Pod the mesh skinning becomes really weird. Initially I thought it was my code that was faulty, but PVRShaman shows the same result. I don’t know if it’s the original Collada-file that is faulty, or if it’s Collada2Pod or my settings.

Could you guys help me out and figure out at which step the bug is at? I have emailed the DAE-file and some of the other formats available + my pod-file. Let’s skip the textures for now because the mail would become too large.

Kind regards, AndreasJackAsser2012-03-30 21:30:20


Just wanted to mention in the thread that I got a personal mail from Scott at Imagination with a solution to my problem:


Thanks for your scene. Unfortunately due to all the Collada exporters interpreting the Collada specification in their own way we can only support files that have been exported using the OpenCollada exporter.

However, I do have a way for you to get your scene to a POD file. Though your scene couldn’t be imported into Max or Maya successfully it did import into Blender 2.59 just fine. If you import it into Blender you can then use our Blender PVRGeoPOD plug-in to export to POD.

Best regards,


Thank you for your excellent support. I’m very impressed by your responsiveness!! :smiley: