Imagination PowerVR SDK Blog

PowerVR SDK Linux installation fails


#1
Hi, 
I fail to install PowerVR SDK (Linux) on PandaBoard (OMAP 4430) running Ubuntu 12.04. 

hjkl@hjkl-dt-panda:~/PowerVR_SDK$ ls
PowerVRSDKSetup-3.0.run

hjkl@hjkl-dt-panda:~/PowerVR_SDK$ ./PowerVRSDKSetup-3.0.run 
-bash: ./PowerVRSDKSetup-3.0.run: cannot execute binary file

hjkl@hjkl-dt-panda:~/PowerVR_SDK$ file PowerVRSDKSetup-3.0.run 
PowerVRSDKSetup-3.0.run: ELF 32-bit LSB executable, Intel 80386, version 1 (GNU/Linux), st
atically linked, stripped

hjkl@hjkl-dt-panda:~/PowerVR_SDK$ ldd PowerVRSDKSetup-3.0.run 
        not a dynamic executable
hjkl@hjkl-dt-panda:~/PowerVR_SDK$ 

Can someone advise?
Thanks.



#2

Ok, I have changed the permissions and ran as super user, still on PandaBoard (ARMv7) - it fails with the following error:


jjhjh@jjhjh-dt-panda:~/PowerVR_SDK$ sudo ./PowerVRSDKSetup-3.0.run 
[sudo] password for jjhjh: 
./PowerVRSDKSetup-3.0.run: 1: ./PowerVRSDKSetup-3.0.run: Syntax error: “(” unexpected
jjhjh@jjhjh-dt-panda:~/PowerVR_SDK$



#3

Hi Rasko,


The SDK installer is a graphical utility designed to install the SDK on a desktop class linux distribution like Ubuntu, or Arch etc.  Specifically, it is designed to be ran on x86 desktop systems, and not embedded systems.  One the SDK is installed on the desktop system it can then be used to target an embedded system (such as the Pandaboard).

Regards,
Bob

#4

Bob,

thank you for the quick reply.

My Pandaboard runs Ubuntu 12.04 image [http://cdimage.ubuntu.com/releases/12.04/release/], in which I have installed OMAP4 Graphical Addons  - OpenGLES 1.x & 2.x Graphics Driver Binaries and mesa-utils. 
I thought I need the PowerVR SDK to have all the run time libraries for running OpenGL demo’s, as I currently fail to run/build the binaries on PandaBoard.

Can you please specify (or forward me) what are the SW requirements (libraries) for building&running OpenGL demo’s/applications on PandaBoard?

Thank you for your help,
Rasko.

#5

Hi Bob,

I encountered installation failure of the PowerVRSDKSetup-3.0.run on my Mint-Linux 64bit too, I ran the following command to install the package:

$ sh ./PowerVRSDKSetup-3.0.run

and got following issue:

PowerVRSDKSetup-3.0.run: 1: PowerVRSDKSetup-3.0.run: Syntax error: “(” unexpected

could you help tell me how to run this package, it looks it is a executable file, but I cannot execute it via console and GUI.

Thanks!
ShaderX




#6

There is a known issue with a variety of 64bit Linux distributions where they don’t correctly run 32bit binaries (the installer is a 32bit binary).  During testing it appeared that most distributions come with a lot of the 32bit libraries pre-installed, several don’t however.  We will be putting a page with instructions on our site soon, but in the meantime, try running:


sudo apt-get install ia32-libs

you might, depending on your distro, also have to run:

sudo apt-get install ia32-libs-multiarch

Hope that helps.


#7

Hi Bob,

Thanks a lot for your response!

I have installed ia32-libs in my system, but when I ran “sh ././PowerVRSDKSetup-3.0.run” I still got the same issue, could you help give more comments about it? Whether can the package only be installed on 32bit Linux?

Thanks!
ShaderX




#8

Try running the installer as the Superuser?


Bob

#9



Hi Bob,

New update, I redownloaded the package and changed its mode to executable, then ran it under Superuser mode, it could launch successfully!

Thank you, so much for your great and nice help!Smile

Thanks!
ShaderX







shaderx2012-10-30 03:29:08

#10

I didn’t think about setting the executable bit.  Apologies.  Glad its working.