problem running glutes based opengles 1.1 prog


 I am working on omap3530evm board with armv7 processor it has SGX support

I have a opengles 1.1 specific program which uses opengles graphics utility toolkit glutes, I have cross compiled glutes for armv7 using openembedded cross tool chain and installed the ipk package on omap3 /usr/lib (it has armstrong embedded linux distribution) and sample gles programs are running fine (gles1test1). but when i try to run a  opengles program which uses glutes then it gives a syntax error  like" expected '{' " the code is running fine on ubuntu x86 machine and win32 using opengles1.1 libs and headers.Â

is this because of version mismatch of libGLES_CM.1.3..13.1397 andÂ

can i get corresponding Â for the omap3 board.??

Also when i cross compile glues using openembedded for armv7 it gives compile errors like "undefined reference to glMultMatrixf()" etc

i think it's library version mismatch can i get corresponding and present version is and



Hi All,Â

I searched and looked about this problem and came to know following :

the function glDrawTexxOES is declared static local function which is specified by 't' alphabet inside supplied by TI for SGX graphics and hence my is not able to access the function.Â

is it the issue?? or something else.....

I think similar function cant be made outside (inside the libglutes source code) because it is Hardware (SGX) dependent .

so can anyone help/guide for resolving this issue



glDrawTexxOES is an extension function. Adresses of extension functions should be obtained using eglGetProcAddress and assigned to an appropriately declared function pointer where EGL is initialised. From what you describe it seems like Glut ES, at least with the build options you used, statically links this function, which it shouldn’t if portability is an issue.

okk i got an ipk package after cross compiling my glutes opengles1.x application for omap3 but when i run the executable "roomdemo" it displays the following failure message:

freeglut (roomdemo): failed to open display ''

in win32 using same code and glutes.lib it is running perfectly fine and i used the same libs in win32 (libEGL, libGLES_CM) which came along with the emulator.

so i am struck here... Ouch and dont know exactly why display is giving error SleepyÂ

any valuable guidance would be helpful


Hi, it's error with configuring the glutes for SGX as it is initializing no display wrto SGX so i think for successful porting of libglutes it requires major code changes. thus ending this thread...

so i am now going with platform specific code for my omap3 boardOuch

a simple application worked ...Smile