Imagination PowerVR SDK Blog

Problem with POD Models


#1

Hi!

 

I'm new to the PowerVR SDK and the first thing i wanted to try is to exchange the model in the 'Vase' example by an own model. So i created a simple model of a sphere in 3dsmax and exported it using the PowerVR exporter. In the example i simply replaced the loading of the model. The result was a strange polygoneffect of long, stretched polygons stretching out from the middle of the screen (you get a similar effect if you apply Projectionmatrices the wrong way). It also took much longer time to load the application (while the provided Vase example starts in almost no time, the version with my model (although less vertices and polygons) takes like more than 10 seconds to start)

 

So i tried to open the Vase.max file provided in the example and export this one. I got the same effect. Then i exportet this Vase.max to a .h file to compare it with the Vase.h file provided in the example. I noticed that the two .h files are structured completely different. So - what could be the problem? How was this Vase.POD created if not with the PowerVR exporter?

 

 

Thanks for the help!

#2

btw. i chose the settings by pointing the exporter to a copy of the Vase.pod file, so that it would take the settings from this file


#3

Hi,

 

To help me see if I can reproduce the problem which SDK and version are you using?

 

Thanks,

 

Scott

#4

Hi.

I'm issuing exact the same issue bot in latst oolong engine and pvr sdk (OGLES-1.1_WINDOWS_PCEMULATION_2.04.24.0811).

Does anyone found a solution?


#5

Forget it, already solved