Imagination PowerVR SDK Blog

PVRGeoPod: Dae -> Pod conversion loses animation keyframes - Any ideas?

pvrgeopod
pvrshaman

#1

I have a .dae file with a 150 keyframe animation. I can view the animation in a variety of packages and see the data in plain text.



After exporting, the animation exists in the .pod, but has only one keyframe. I see this same result in PVRShaman or if I load the .pod file in Cocos3D. I’ve tried changing the indexed animation setting. I’ve tried exporting different Collada versions. No luck.



Does anyone have any magical solutions or even ideas I could try? Thanks!


#2

I’ve spoken to the PVRGeoPOD lead engineer, and he’s told me that the COLLADA specification doesn’t specify a naming convention for animations. It may be the case that PVRGeoPOD doesn’t recognise the animation names in your DAE.



It’s also possible that the animations are represented in an unusual way that PVRGeoPOD doesn’t support.



If you can send us a DAE to reproduce the issue with, we can investigate the cause. You can share files with us confidentially by attaching them to a support ticket: https://pvrsupport.imgtec.com/new-ticket



Thanks,

Joe


#3

Thanks, Joe! I will open a ticket.