Imagination PowerVR SDK Blog

Bug in PVRGeoPOD?

pvrgeopod

#1

I have been experiencing some weird behaviour trying to convert Collada files generated in Softimage using the standalone PVRGeoPOD tool.



I create a simple cube, with 2 keyframes, rotating 1080 degrees around the X-axis over a 100 frames.



When I save this scene as a Collada file, and convert it to POD, the resulting POD file does not play correctly, it seems to suffer from a type of gimbal lock, and oscillate back and forth, never making a full rotation.



If I do the same, but rotate around the Y or Z axis it all works as intended it’s only rotations around the x-axis that are affected (I diffed the input Collada files, and the different axis to rotate around is the only change change)



I tried plotting the animation when exporting to the Collada file ( so the Collada file contains 100 keyframes ) thinking this might be an interpolation bug, but exactly the same happens.



I’ve also tried exporting the pod file with “Store animation as matrices” but that made no difference either.



If I Import the Collada file in Maya, and save it to POD using the provided Maya 2013 plugin, the rotations around the x-axis works as intended.



The collada files validate against the 1.4.1 spec.



I’ve taken the liberty to also mail this with the files attached to devtech@imgtec.com as I’ve seen requested on other bug queries on this board.



Thanks,

Willem


#2

Hi,



Thanks for your files. I was able to reproduce the issue and found it to be a bug in PVRGeoPOD. Our next SDK release (3.1) will contain a fix.



Thanks,



Scott


#3

That’s great!



Any rough idea when this will be released?



Thanks again for the great SDK and resources, they are really helpful!


#4
That's great!

Any rough idea when this will be released?


We're aiming for the end of February.

#5

Hi,



We will aim to release our 3.1 SDK at the beginning of March.



Regards,

Joe