Imagination PowerVR SDK Blog

Trouble running OpenGL ES2 SDK tutorials


#1

Hi,

I’m having trouble running the PowerVR - Khronos OpenGL ES 2 SDK tutorials for the Nokia n900 as per https://www.imgtec.com/powervr/insider/s … S2xSGX.asp.

I am using the Scratchbox cross compilation toolkit to compile for the

n900 and have previously managed to build and run some simple OpenGL ES

2 applications on the system. However when I try to compile the

tutorials, I am faced with the following error (in the last two lines between the borders):

===START ERROR MSG======================================================================
[sbox-FREMANTLE_ARMEL: ~/workspace/tut3/OGLES2/Build/LinuxGeneric] > make PLATFORM=LinuxOMAP3

***********************************************

Name: OGLES2IntroducingPVRShell
PWD: /home/mvl/workspace/pwrVRshell/OGLES2/Build/LinuxGeneric
Binary path: /home/mvl/workspace/pwrVRshell/OGLES2/Build/LinuxGeneric/…/LinuxOMAP3/ReleaseRaw
Library path: /home/mvl
WS: Raw

******************************************************
+c+ …/LinuxOMAP3/ReleaseRaw/OGLES2IntroducingPVRShell.o
/scratchbox/tools/bin/sh: line 1: arm-none-linux-gnueabi-gcc: command not found
make: *** […/LinuxOMAP3/ReleaseRaw/OGLES2IntroducingPVRShell.o] Error 127


===END ERROR MSG========================================================================



I

have previously managed to get OpenGL ES2 applications running for the

n900, but am not 100% sure I have followed the steps in the user guide

properly to set up the tutorials environment as per section ‘3.2

Linux’, pages 15/16 in the User Guide. This is how I followed the steps:
1 Ensured OpenGL ES2 libraries are installed
2 Set up the LIBDIR to point to OpenGL ES2 library files in /scratchbox/users/mvl/targets/FREMANTLE_ARMEL/usr/lib.
Such files included in directory are libGLESv2.so
3 Installed the latest toolchain with Scratchbox
4 Pointed the TOOLCHAIN variable to the toolchain at /scratchbox/compilers/cs2007q3-glibc2.5-arm7/bin
Such files included in directory are arm-none-linux-gnueabi-c++ arm-none-linux-gnueabi-gcc
This I’m a bit more unsure about but seems I did the right thing there.
5 Compiled with ‘make PLATFORM=LinuxOMAP3’ which comes up with the error message above.


Note: I have also tried for an X11Build but that comes up with the exact same error message.

Any help much appreciated.


#2
Hi,

 

If you set the TOOLCHAIN variable to

 

Code:

/scratchbox/compilers/cs2007q3-glibc2.5-arm7

 

does it fix the problem? Reason I ask is that the TOOLCHAIN variable is used in /Builds/OGLES2/LinuxOMAP3/make_platform.mak and expects it not to include the bin/ directory.

 

Thanks,

 

Scott
Scott2010-05-04 16:39:27

#3

Yep, thanks, that fixed it.