Imagination PowerVR SDK Blog

Pod Animation is completely corrupted

pvrgeopod

#1

Hi,

I’m starting to have an issue with exporting to Pod from maya. I have a mesh and a skeleton, and in the past, when I export, it’s totally fine. However just today, when I export, the mesh becomes wildly distorted, as if the bones are scattering all over the place, pulling the mesh all over. What’s weird is there is still movement. So the character just gets wildly stretched, like it has spider legs or something.

I tried exporting a different character to see if I had the same issue; i did. I reinstalled the plug-in for it. Didn’t help. I don’t know what happened really.

Any thoughts on what on Earth is happening?

I’m using Maya 2013, and exporting with the 2013 version of the PVRGeoPOD plug-in.


#2

Hi,



Are you using a custom configuration in PVRGeoPOD? Have you checked the channel swizzling options for the data you’re exporting (A0,A1,A2,A3)? Does the exported POD file behave correctly when you use the default config in PVRGeoPOD?



The PVRGeoPOD configuration file will not be modified after a reinstall, which may explain why the issue has persisted. You can find out more about our configuration files here.



Thanks,

Joe


#3

How do i access the .plist? i don’t understand where that directory is.


#4

We have an FAQ item that explains where the .plist configuration files are stored:

http://forum.imgtec.com/discussion/3459/where-can-i-find-the-powervr-tools-configuration-files-e-g-pvrshadereditor-plist#latest



Joe


#5

Ok. I wasn’t clear.



I followed that first link you provided and didn’t understand where I can go to look for “~/.pvrconfig/Imagination Technologies/”. I’m seeing your second link, which goes to the same place as before. So I’m assuming my question isn’t clear.



How do I find “~/.pvrconfig/Imagination Technologies/”? I have a Mac, and am not sure where to start looking. Is this something I can find in the Finder? Is it only accessible through Terminal? Is it in the Package Contents of the app?



Feras


#6

Hi Feras,



Thanks for the clarification. The ‘~’ character is used in Unix-like operating systems to refer to the current user’s home directory. A ‘.’ prefix (e.g. ‘.pvrconfig’) denotes a hidden folder. Hidden folders are not shown in Finder by default.



You should be able to access the folder in Finder by clicking Shift+CMD+g on your keyboard to bring up the “Go to the folder:” dialog. Once this dialog is open, you can copy and paste the ‘~/.pvrconfig/Imagination Technologies’ directory to the text field, then click ‘Go’ to navigate to it.



Alternatively, you can access the directory from a terminal window.


#7

Hi Joe,



So it seems like when I look for the file, I get a message that it’s not found, or that it doesn’t exist. Any idea what that’s about?



Thanks!


#8

The file will be created after the first launch of the corresponding utility. For example, a default .plist file will be generated the first time PVRGeoPOD is executed.



If you have removed the file already or have not ran the utility yet, the file will not exist.



How did you try to access the file? From Finder, or from the Terminal?


#9

I accessed it from Finder.



My first attempt to correct the issue was to remove the plug-in, then reinstall it. That didn’t change anything.



However, this is my first attempt to access the file. So I haven’t touched it before.


#10

I’ve tried navigating to the directory on a Mac and have figured out the problem. For some reason, Finder doesn’t like escaped space characters. If you use the following path, you should be able to access the directory:



~/.pvrconfig/Imagination Technologies



Alternatively, you can go to the .pvrconfig directory in Finder, then navigate to the Imagination Technologies sub-directory.

~/.pvrconfig


#11

Awesome! Thank you! I found it!



How do I send you the corrupted .plist files?


#12

If you need to send files containing confidential information you can attach them to a new support ticket, remember to link back to this thread: https://pvrsupport.imgtec.com/new-ticket