Imagination PowerVR SDK Blog

Download older version of 3ds max plugin


#1

Just started using oolong engine that uses imagination technology as a foundation, but the new file format of the POD:s exported are not yet supported in oolong. So is there any way of downloading older releases of the SDK and utilities?

It would be great if I could get hold of a plugin for 3ds max that allows me to export into the older format.

Best regards,

Jimmy


#2

Jimmy,

 

We believe there will be an update of the oolong engine shortly.

We will update our web site as well to accomodate the previous version of the plug-in.

 

Best regards.

 

Carlos.

#3

Hi Carlos,

thank you for the reply!

I’m looking forward to the Oolong engine update, tried the other day to do adjust the output file that i got from your tools manually the other day, but couldn’t quite get it to conform with what the engine wanted.

So right now I think my plan is to wait for the older version of the plugin or the engine update.

Br,

Jimmy


#4

Jimmy,

 

Now you can get it from here:

https://www.imgtec.com/powervr/insider/powervr-pvrgeopod.asp

 

Best regards.

 

Carlos.

#5

Hi Carlos and thank you for the link.





Downloaded it and tried it last night but still was not successful, it appears that the vertex pointer in the mesh I’m exporting ends up as a nill pointer, the faces are pointing at the face list but the vertecies are pointing towards (unsigned char*) 0.





I’m exporting to an .h file from 3ds max 9. Is this a known problem?


#6

It sounds like you have “interleaved” ticked in the exporter. In that case, the pointers are offsets into the pInterleaved array - you can either untick the box, or change your code to support interleaved vertex data.





Regards,


Aaron.


#7

Excelent! That did the trick!





Should have looked a bit further into my own code first :slight_smile:





Thank you so much for the pointers Aaron and Carlos!