Imagination PowerVR SDK Blog

Max plugin problem when exporting skinning mesh

pvrgeopod

#1

Hi,

 

I got a problem when exporting a skinning mesh by PVRGeoPOD 3dsmax9 plugin. The console log show "File not wrriten - scene processing for export failed" if any bone in the skin-mesh contains more than two child bones. Then I reduced the number of child bones to 1 or 2, it will be OK. So I wonder if it is the limitation of PVRGeoPOD plugin or just a bug?

 

Best regard,

Jerry

 

#2
jerrychio wrote:
Hi,
 

I got a problem when exporting a skinning mesh by PVRGeoPOD 3dsmax9 plugin. The console log show "File not wrriten - scene processing for export failed" if any bone in the skin-mesh contains more than two child bones. Then I reduced the number of child bones to 1 or 2, it will be OK. So I wonder if it is the limitation of PVRGeoPOD plugin or just a bug?

 

Best regard,

Jerry

 
 

Hi,

 

It sounds like a possible bug. If possible could you send your Max scene complete with a screenshot of your exporter options to devtech@imgtec.com so we can see if we can reproduce it.

 

Thanks,

 

Scott

#3

Thanks for your files. I’ve taken a look and have found 2 causes of the “File not writen - scene processing for export failed”. The first is that the POD format only supports up to 4 bones per vertex and your scene exceeds this limit. This can be fixed simply by changing the value of ‘Bone Affect Limit’ under ‘Advanced Parameters’ for the Skin modifier. The second is that the value being used for ‘Max simultaneous matrices’ is too low for the scene so the bone batching is failing. Ideally if you’re exporting with a limit of 3 bones per vertex this should be set to 9 as that will be the maximum number of bone matrices affecting a triangle. With these two problems fixed your scene exports fine for me.