Imagination PowerVR SDK Blog

Memory leak in PVRTune?

pvrtune

#1

I’m trying to play with the PVRTune application provided as part of the PowerVR SDK from TI for the OMAP Zoom1 device. I’m got the sgx_perf_server running on the device & when I connect to it, the device says:





Accepted connection from 172.24.90.21…                                      


Connected.                                                                    





However I’m having some trouble with the PVRTune application. It seems to have a memory leak as it hangs and very quickly takes up >2GB of virtual memory. Exactly the same happens on both the Linux and the Windows PVRTune.





Is this a known issue? Is there a fix anywhere?








Cheers,





Tom








PS: You really should consider writing PVRTune using Qt.






#2

This is actually something we noticed last week at GDC and I believe it to be a fairly recent addition/problem in the code.





We’ve added the issue to our tracking system (BRN26958) and someone will post back here when it’s resolved.





(Point about Qt noted.)






#3

I’ve just tried again with a PVRTune executable from a 2008 SDK and had the same problem. Perhaps it’s actually the sgx_perf_server which is causing it? Although the app should still not behave like this.


#4

It looks like the problem is less recent than I thought…





The engineer who works on this is away at the moment, but I’ve no doubt this issue will be high on his priorities when he gets back. Thanks for reporting these problems.


#5
TomCooksey wrote:
It seems to have a memory leak as it hangs and very quickly takes up >2GB of virtual memory.



It sounds to me like you're actually seeing an old fixed bug (BRN26954 or BRN25519). From what you've said I think the issue that Gordon is referring to (BRN26958) is different (and is fixed for the 2.6 release).



1) Does this hang happen as soon as the connection is made or do you see data arriving for a while first?

2) Can you list the version of your SDK, DDK, PVRTune and SGXPerfServer?



Thanks,

Aaron.

Aaron2010-03-16 16:19:45