Imagination PowerVR SDK Blog

PowerVR Graphics SDK v3.5, AEP unavailable.

pvrvframe

#1

PVRVFrame 10.1 (SDK build 3.5@3510720)
32bit app.
Running the host profile.

OS: Win10x64
GPU: Nvidia GTX 970 driver 355.82

Context1:
OpenGL ES (emulated)
Version: 3.1
Shading language version GLSL ES1.0 <- ??
Extensions: 69

Open GL (host)
Version: unknown
Shading language version: Failed to query GLSL version
Extensions: 333

None of the expected AEP extensions are available.


#2

Have you tried setting PVRVFrame to loose mode?


#3

Yes I tried both strict and loose.
No difference.


#4

Hi Rene,

Do you have a simple reproduction application for the issue that you can share with us?

Thanks,
Joe


#5

Yes I can provide you with a executable if you want.
How can I share it privately?


#6

Thanks Rene. I suspect a test would be fairly trivial for us to code, but we can’t allocate time to this at the moment (everyone’s very busy finishing the upcoming 4.0 SDK release).

You can share files confidentially with us through our ticketing system: https://pvrsupport.imgtec.com/new-ticket
Note: The ticketing system requires a separate registration from the forum. Registration and support through the ticketing system is also free of charge.


#7

Ticket Ref: 558


#8

Thanks for sharing the repro with us. The PVRVFrame lead found and fixed a few bugs. Your app now runs correctly in our emulator. We’re due to release the 4.0 SDK in a few weeks. If you are keen to get an engineering drop with the fixes, we can share a package with you through our support portal.

For reference, here are the bugs that were fixed (changelist 3721434):

  • glDrawArrays wasn’t accepting the GL_PATCHES draw mode
  • The geometry shader crashes our shader validator. We have worked around this by disabling geometry shader validation (we will report the issue to the compiler team, who maintain the validator)
  • EXT_tessellation_shader wasn’t showing up in the extension list due to a typo. All other AEP extensions seem to be working fine
  • Due to another validator bug, we have to define gl_in[gl_MaxPatchVertices] instead of gl_in[]