Imagination PowerVR SDK Blog

SDK R1 2017:Can't compile shader with #version 320 es

pvrvframe

#1

Hi!

Thanks for new SDK R1 2017!

glGetString(GL_SHADING_LANGUAGE_VERSION) -> “GLSL ES 3.2(Host: 4.50)”

I can’t compile any shader with version > 310 ES, but:

OpenGL ES 3.2 implementations are guaranteed to support versions 3.20, 3.10, 3.0 and 1.00 of the OpenGL ES Shading Language
https://www.khronos.org/registry/OpenGL/specs/es/3.2/es_spec_3.2.withchanges.pdf

Can you fix it ?
Thanks!


#2

Hi Andrey,

Thank you for bringing this issue to our attention, we are looking into the issue now and we will get back to you as soon as possible.

Kind Regards,
Shaun


#3

Hi Andrey,

We have identified the bug in PVRVFrame which is causing the issue you are describing, unfortunately a fix for this issue will not be available until our next public release, we sincerely apologise for any inconvenience caused.

Kind Regards,
Shaun


#4

Hi Shaun, Thank You!

May be for next release of PowerVR SDK, i will use the Vulkan API :slight_smile:


#5

I"m experiencing the same issue, there seems to be a regression in this version of the emulator. I start a separate thread one of my other issue.


#6

Hi Carrado,

We are aware of this issue, and we are aiming to fix it by the next public release of our SDK.

Thanks,
Shaun