Imagination PowerVR SDK Blog

PVRShaman Segmentation faul on linux 32

pvrgeopod
pvrshadereditor
pvrtextool
pvrshaman

#1

DEAR TEAM


using the new sdk 3.0 i have the following error runing  PVRShaman on ubuntu12.04 / 32bit

~/MegaPowervr/PVRShaman/Linux_x86_32$ ./PVRShaman 
QLocalSocket::connectToServer: Connection refused

~/MegaPowervr/PVRShaman/Linux_x86_32$ ./PVRShaman 
Segmentation fault (core dumped)


the previous version work fine of course on the same plateform

the shader editor have the same problem but all other tools are up and running.

any idea ???
Kind regards
david

#2

Hi david,

The Connection refused message you’re seeing is displayed after an application fails to shut down properly (i.e in the case of a crash).

Can I ask if PVRTexTool works for you? This uses the same code to manage windows as PVRShaman and PVRShaderEditor.

Regards.

#3

i just reinstalled the UBUNTU and the sdkl !!

I have the same error from the first run just after the install completed

PVRGeoPODGUI does work for me but not PVRTexTool from the sdk 3.0.

The previous sdk work fine.

regards
david




#4

Hi David.

We’ve replicated the issue and are presently looking in to a fix.
The reason that the previous SDK works is that SDK 3.0 uses an entirely new GUI API than the previous release, hence the differences.

As a work around, you should be able to launch the utilities if you’re root. You can either do this via su, sudo or gksudo.

Regards,
Arron.

#5

Hi


good stuff i am sure you will find it.

dont you know if you will make an update about this essential tools ??

kind regards
david


#6

Hi David.

Indeed, when the problem is solved we will release updated versions of the relevant utilities.

Best regards.