Imagination PowerVR SDK Blog

PVRTexTool crash, Linux 32/64, amtc_localised.c:8074: DetermineABUpdates assertion failed

pvrtextool

#1

Hello,



Attempting to compress a texture using PVRTC2_4 crashes (while PVRTC2_2 and other formats pass.)



>./PVRTexToolCL -i test.png -o test.pvr -l -f PVRTC2_4 -q pvrtcbest

…*…*Assertion Failed:/usr/buildxl/buildroot/sdk/branch/UtilitiesSrc/PVRTexTool/Library/Source/Codecs/PVRTC/amtc/amtc_localised.c:8074:fabs(ModVariance) > 0.0

Need a debugger break on line /usr/buildxl/buildroot/sdk/branch/UtilitiesSrc/PVRTexTool/Library/Source/Codecs/PVRTC/amtc/amtc_localised.c:641

PVRTexToolCL: /usr/buildxl/buildroot/sdk/branch/UtilitiesSrc/PVRTexTool/Library/Source/Codecs/PVRTC/amtc/amtc_localised.c:8074: DetermineABUpdates: Assertion `fabs(ModVariance) > 0.0’ failed.

Aborted (core dumped)





I’ve tried the above with a PNG made of random noise and it worked, so there’s a specific problem compressing my texture (which is a spritesheet / atlas), which you can find here:



http://onetacoshort.com/temp/test.png



Installation details:



PVRTexToolCL version 3.40

Uses: PVRTexLib version 4.5 | JpegLib version 6b | Libpng version 1.5.12





Best,

-Jeff


#2

Hello

i ve tried your sample and the tools effectively crash like you describe but Succeed using the GUI TOOLS

Since other format of compression are working, can it be a solution for you ?

I am using PVRTexTool GUI 4.4 on UBUNTU 32!!!

other format that i tried are taking age by command line but i think a solution is coming …i believe so :slight_smile:

regards

david


#3

Thanks for the response, David. Unfortunately, I’m building our asset workflow, and I need the commandline to produce best quality results (slow is acceptable).



Also, the above settings crashesd the GUI for me. Steps are:


  • Open test.png
  • Click optimize transparent, bleed
  • Click compress
  • Choose “OpenGL ES 2” as the group
  • Choose PVRTCII 4bpp
  • Choose best quality
  • Check generate mipmaps (no other checkboxes)
  • Click encode
  • Crash, terminal shows same output - DetermineABUpdates assertion failed



    My workaround is to use PVRTC1_4 for now.

#4

based on your pics, yes it does crash my GUI as well and command line , by selection an another png that i am using for my project it does nt not i am wondering about your setting of png creation then (nearest power of two etc etc)?



but sure a crash like this is not a normal behavior, only the Team can answer that one :slight_smile:



regards

david



#5

Hi Jeff,



Sorry for the delay in answering you - I’ve been investigating and we’ve managed to pin down the issue. I’ve added a temporary fix which will make it into REL3.2, but won’t be present beforehand. A permanent fix should hopefully be available before we actually release though, solving the issue properly. In the meantime, if you want I can provide you with an engineering drop that should solve the issue for now - if you email DevTech@imgtec.com, I can send you a copy.



Thanks,

Tobias



#6

Thank you Tobias. I’ll send you an email shortly.



Best

-Jeff