Imagination PowerVR SDK Blog

PVRTune data incorrect?



While profiling using PVRTune, I found GPU frame earlier than CPU frame in the timeline, I think it’s supposed to be one or two frames behind the CPU frame. Is it a bug or I missed someting? I tried on PVRTune 14.141 and 14.137, both the same.


Hi Jarod,

Thanks for sharing the recording. It looks like the CPU timing data frame number is out of sync with the GPU render. I suspect this is a bug in PVRTune related to recording from a non-zero frame number.

Are you able to reproduce the problem when recording from frame 0?


Hi Jarod,

I’ve discussed the issue with the PVRTune lead. He suspects that it is caused by the device reporting the GPU clock speed at an insufficient frequency, which is in turn causing the GPU timing data to not align with the GL call timing data in PVRTune. Unfortunately, the only way to resolve this problem is to capture PVRTune recordings on devices with v1.5 or better drivers. Unless the device OEM provides an update for the device with new graphics drivers, it’s unlikely that you will be able to resolve the issue.


I’ve no idea if this is the correct way to record from frame 0: I use PVRHub record the file to my phone and then download to my pc, open it with PVRTune, but it shows the same result as before, one frame earlier than the GPU frame time.

How could I know the powervr driver version, any command line to print it?


Hi Jarod,

You can find instructions for querying the driver version string in this FAQ item.

You can record from frame 0 by using PVRHub to launch your application. If the application is already running before the recording starts, frame 0 (and a bunch of other frames) will have already rendered.


Hmm, attached my driver info, so I guess this “Rogue Version:” is the driver version?

In my previous test, I did quit all applications, and launch my game from PVRHub, result is still the same.


Hi Jarod,

Thanks for sharing the information. is the GPU hardware revision. 1.4@3443629 is the driver version.

We have confirmed that the issue is caused by PVRTune not receiving dynamic clock speed change information from the driver. As mentioned above, this feature was only added to our 1.5 driver branch. Unfortunately, there will be no way to workaround the problem with the driver revision you have.

I’ve filed a bug report against the PVRTune User Manual to list known driver limitations (BRN59988).


Oh, I see, thank you Joe, it looks like nothing I can do but waiting the lazy OEM update their driver :frowning: