Imagination PowerVR SDK Blog

Shaman won't render texture

pvrtextool
pvrshaman

#1

I have install version 3.0 of the PowerVR SDK on my Mac Book Pro running Mac OS X 10.7.5. I am using Maya 2010 and I have exported a textured cube to a POD file.


When I go to open the exported POD file in PVRShaman, the cube appears in the render window, only there is no texture applied to it. The texture file name appears under the applied material in the Scene Explorer. I can double click on the texture file and open it in PVRTexTool, so there doesn’t seem to be any problem with the application finding the texture, yet it does not appear on the cube.

What is needed to get the texture to render?


#2

Hi.


We haven’t had any issues like this reported against PVRShaman. Have you made sure that you’ve exported the UVs during the export process? Also PVRShaman only supports reading UVs from the first channel so please check this too.

If this doesn’t solve the problem then could you please email us the offending POD file to devtech@imgtec.com and we can take a look for you.

Many thanks.

#3

I am having a similar issue. I have created a pfx file that uses textures. When I load the pod file the material appears grayed out, and remains so until I create a new material and associate the pfx file with it.


#4

Hi Evansjaw.

PVRShaman will possibly grey out the material if there is an error with the material or some other problem with it such as not being able to load the associated texture. However, it may be bug in PVRShaman. If you are still having issues feel free to email the POD file to us at devtech@imgtec.com.


#5

I had to check the “Export mapping channels” option in the export settings and then it was able to successfully export so that the texture would display in PVRShaman.