Imagination PowerVR SDK Blog

wglChoosePixelFormatARB missed.

pvrvframe

#1

I ran some demos from SDK2.0, but it said miss the PVR function:wglChoosePixelFormatARB

is someone meet the same problem? how to handle it?

Thanks!


#2

This means your graphics driver lacks the WGL_ARB_pixel_format extension. What graphics hardware are you using?


#3

I found it. I used the remote control, failed since it is missing.But if I use the desktop run it, no problem.

It seems, my laptop, which remote the lab desktop has some hardware missing.

Is that right? Thank you!


#4

As far as I know you cannot run OpenGL applications in Windows Remote Desktop. You’ll have to run the applications locally.


#5

Yeah, I think that is the key. But, why? Is there any solution that run OpenGL demos by remoting desktip?

Thanks a lot!


#6

The remote desktop server essentially replaces the graphics driver of the remote machine and transmits the graphics commands to the client. It doesn’t handle OpenGL, though.





If you can remote desktop you should also be able to share files and run them locally. But if your laptop doesn’t have OpenGL 2.0 graphics drivers then I don’t think there is a solution.


#7

Hi, I don’t think my laptop has no support for OpenGL ES, but may need some files, such as the wgl… as I mentioned.

Is there a solution that could overcome this problem? Thanks.


#8

Your laptop needs to support OpenGL 2.0 plus some extensions. OpenGL ES support is enabled by a wrapper on top of OpenGL 2.0 that comes with our SDK.






#9

Oh, I see. Thanks, I would have a try.


#10

I have encountered this problem.

 

However, I use the ATI fireGL V5200, it claims that it supports OpenGL 2.0.

 

Can you help on this problem?

 

Thank you very much!

#11

Are you getting the exact same message and are you also on Windows? Are your drivers up to date?





I think your card should be able to handle PVRVFrame fine.


#12

I am using XP Professional.


However, it seems to be the obsolate driver version.

After I update to newest driver, it works.

 

Thank you very much!

#13

In my experience it’s always worth checking your drivers are up to date for these kind of problems. Glad it worked


#14

Hi,

I have same error: wglChoosePixelFormatARB missing. My laptop gfx card does not support OpenGL 2.0, but I am trying to run SGX Demo with Mesa3D library which is supposed to implement OpenGL 2.0 in Software. I am copying the Mesa DLLs (GLU32, OPENGL32, OSMESA32) close to the demo executable.

Am I missing something?

 

Please help. Thanks.

#15

I don’t believe PVRVFrame works with Mesa, I’m afraid.