Imagination PowerVR SDK Blog

mesh isn't showing up in Shamen

pvrtextool
pvrshaman

#1

I’m a new user to the PVR tools and I’m trying to view my meshes in Shamen. However, although it appears to be exporting correctly and there are the correct number of faces in the Shamen editor, it doesn’t show up in the viewport.

I tried opening the samples (specifically, the mask) that came with the utility, but nothing appeared. I’m exporting an openGL format, and I tried opening that version of the mask, as well as every other version, but to no avail.

Any ideas what I’m doing wrong?


#2

So, our programmer is having the same issue with the exported meshes not showing up in Shamen (on a completely different machine).

Is there no one that has an idea why this is happening?


#3

This is being pursued under BRN26985 (and via email).


#4

Do we need to have the entire SDK, or is simply installing TexTool and Shaman enough?


#5

Upgrading the graphics card drivers solved this problem.

PVRTexTool and PVRShaman (and the other utilities) can be used without installing the whole SDK.



Stefan.


#6

yes, it was a bit tricky to do that. For anyone else running into this problem:

I have an ATI Mobility Radeon x1400 and for some reason, when you try to update the drivers through Windows, it says they are up to date (even if they’re not). So I had to uninstall the drivers and install the ATI drivers from Overdrive.net, which included OpenGL 1.2. This finally fixed the problem.