Imagination PowerVR SDK Blog

The latest PVRTexToolGUI doesn't work on Mac...

pvrtextool

#1

Hi,


I have downloaded PVRTexTool_2.07.27.0493.zip but I’m not able to run MacOSX version of PVRTexToolGUI. Even its icon is just an empty rectangle. I have tried to download it using Chrome and Safari. ZIP archive is uncompressed without a problem in both cases. When I want to run the tool, OSX asks to confirm that I want to run an app downloaded from internet (just for the first time) and then Terminal is run. After that, nothing else happens. The same tool from PVRTexTool_2.06.26.0649.zip works without a problem. My MacBook is 13" ALU version from 2008, currently with Mac OS X 10.6.4.


#2

Thanks for reporting this. The PVRTexToolGUI application seems to have read-only permission in the package on the website. This seems to have happened in our final packaging step as the build we take it from works fine.

Setting the permissions on the file seems to fix it with a line like:

Code:
>chmod 755 PVRTexToolGUI


Or you can do the same through Get Info in the Finder.

We'll try to get this fixed as soon as possible, however. Please post again if that doesn't fix your issue.


#3

Now it works great, thank you!