Imagination PowerVR SDK Blog

PVRShaman Qt5PrintSupport.dll issue

Hello everyone,

I’ve tried searching forums but did not find any information on this.
Has anyone else encountered this issue?
I downloaded PowerVRSDKSetup-2018_R2 and after installation and trying to launch PVRShaman I an error:
"The code execution cannot proceed because Qt5PrintSupport.dll was not found. Reinstalling the program may fix this problem.

I tried reinstalling the program and it did not help :frowning:

Any advice is appreciated.

I am running windows 10 Pro

Stan

Hi Stan,

This is quite a strange problem. It has not been reported before and we did not found it in our testing. We have tried to replicate your problem and run to PVRShaman from our 18.2 release on a Win10 machine that does not have Qt installed and it works fine. Also in a machine with Qt installed.
Qt5PrintSupport.dll is a dependency we had in the past but not anymore. I am wondering whether Qt is picking up the libraries from somewhere in your system. Do you have Qt installed and in your path?
Another thing you could try is to rename the exe to PVRShamanGUI.7z (it is a compressed file). Uncompress it and run it directly from the folder to see whether it makes any difference.

Regards.

Carlos.

Hello Carlos,

I tried your suggestion and it did not work :frowning:
Still give the same error. I went ahead and found that DLL online and when I place it in to that unpacked directory I get new error message when the Qt5PrintSupport.dll is added:

“The application was unable to start correctly (0xc000007b). Click OK to close the application.”

I do not have Qt installed on my computer BUT for test purposes I did have it installed and the result was the same.

P.S. I did not have any issues running previous version of PVRTools.

Thank you,
Stan

Hi Stan,

I cannot think of anything that might explain this behaviour. Maybe it is caused by the path where the application is installed (too long or with odd characters)? We cannot replicate it here so it is quite difficult for us to find out which is the issue. It might be better for you to move to an older version if it works for you. You can find our legacy downloads page here: https://www.imgtec.com/developers/powervr-sdk-tools/legacy-downloads/

Regards

Carlos.

I also seem to be having this issue. 2018_R2 on Win 10 Pro

A quick search for the error message suggests that this error is quite common in Qt
Among other things "Error 0xc000007b is commonly caused by mixing up 32-bit and 64-bit libraries. "

Hello,

This is quite strange and we haven’t been able to replicate this problem here. I have run Dependency Walker on the binary and there is no mismatch as afar as I can tell. The application carries all the required dependencies. Maybe it is not picking up the right libraries. Do you have Qt by any chance on your PATH?

Thanks.

Carlos.

Hello,

We have fixed this problem with the missing QT library. We will release a new version of PVRShaman shortly. In the meantime you can get the DLL from this post Just copying it somewhere in your path should fix this problem.

Thanks.

Carlos.

This post https://forums.imgtec.com/t/pvrshamangui-exe-cant-find-qt5printsupport-dll/2969

Thank you!
Placing that dll in to a directory fixed the issue :slight_smile: